1TB My Book Essential USB = Broken

I’ve got a 1TB My Book Essential , and I’m wondering how I can access the data without USB, as the jack within the My Book has broken off from the board. The drive worked perfectly fine up until that point, and smart tests detect that the drive is still OK. Unfortunately this edition has no eSATA or FireWire adaptability, so without the USB I’m forced to take the casing apart and retrieve the drive inside.

I’ve now tried using the inside Caviar Green 1TB(Advanced Format) drive through a SATA to USB converter, but the format is still not recognized and it turns up as an unallocated file system. As I understand it, the problem is that the drive is encrypted and the converter in the MyBook decrypts it before it converts it to USB 2.0 – hence the “unallocated” issue when it’s not properly decrypted.

So finally, do any of you know of a way(free) to still access that data? I suppose I could try and get the part with a fresh USB jack for the MyBook, but I’d like to avoid unnecessary expenditures if possible.

Thanks in advance :slight_smile:

Edit: I’ve read that replacing the board is impossible. The encyrption is supposedly unique to each PCB, meaning that the only option IS to solder the jack back on and/or splice some wires. I guess I’m going to have lots of fun doing just that over the holidays. I definitely wont be purchasing a hardware encrypted drive in the future. I’m also terrible with jacks – I’ve broken off a DC power jack and 4-5 of the USB ports on my last 2 laptops(I bump the cords around a lot).

Well think I’m done with this one, I had what I thought might’ve been right, but it was just a bust. I guess I’ll be simply reformatting the drive and getting on with life – I’ve read through countless failed stories of others with the exact same issue, and wont bother wasting more time to fix the problem at this point.


I was going mostly by eye off this image here of someone who successfully managed to recover data from a clients MyBook who also had the exact same problem as me(it seems it’s actually quite common!). I don’t however have the same equipment nor level of expertise, and I’m satisfied just having actually tried instead of giving up right away.

I have that problem too but I can’t fix anything, what can i do please?

The drives have a board that provides encryptin whether you use a password or not. The boards are not  interchangable. You might try an electronics repair person and see if they can solder on a new port.