1st Gen not showing under Computer Section of Network

Hello all, I’ve tried using the search and although there are plenty of posts, all are quite outdated.

I have a newly acquired (used) 4TB first gen unit. I am fully aware that support has ended for this 1st gen unit, and that I should be able to use it locally only - which is my goal. I have 2 other OS5 units that are fully functional, and all is good with those including cloud access.

The 1st gen unit appears to have been updated to the latest firmware which removed cloud access (I’m ok with that). Win10 downloaded the drivers, and the Gen1 now shows up under my Storage and Media section - but NOT under the “Computer” section of my network which is where/how I would map my shares. My other 2 MyCloud devices show up there under Computer as well as storage and media.

I read someone say that they had to use WD Access in order to access a Gen1 device after support ended. I was wondering/hoping there was a way to allow it to show up under the Computer Section as I’d prefer not to use extra software, or is this something that has changed due to the lack of security of OS3? Appreciate any info on the matter.

Couple of suggestions. Reboot the computer if you haven’t done so already as a troubleshooting step. Have you performed a 40 second reset of the single bay My Cloud? Sometimes a 40 second reset can fix weird issues. Check the single bay My Cloud Dashboard and ensure the workgroup name is the same as the computer’s (usually “workgroup”). On the Windows PC, make sure SMB1.0 is enabled. Also check that the Windows Network Profile is set to Private and not Public.

My Cloud OS 3 Pin Reset and System Only Restore a Single Bay My Cloud Device

My Cloud, Home & My Passport Wireless: Enable SMB 1.0/CIFS File Sharing Support on Windows 10 & 11

Thanks Bennor. The Gen1 MC was factory reset, but I didn’t actually do the 40 second reset, so I will try this.

Everything else is working properly, the workgroup is named workgroup and SMB is enable as I have 2 other my cloud devices which are fully functional and all set up the same way (other than 2 running OS5, and the gen1 running OS3).

So - - - - I have a few OS3 devices on a network.

NONE of those devices reliably shows up as a computer under Network; on any of the three Win10 machines that routinely access my network.

I generally access the devices by typing \\device_name or \\ip_address in a file explorer address bar. Works like a champ. Everytime. Usually, after accessing once. . .the OS3 devices will show up in the “computer” section. . . .until the next reboot. (Note: I assign a fixed IP address from the router for the NAS units)

I have scoured the net for a resolution; but alas my Google-Fu was not up to the task. I suspect it has something to do with the “master browser” routines. . .but I have not found a permanent fix. I ran an OS5 box for 6 months. . . .and this “bug” appears to be one of the two notable fixes I liked with that firmware.

Vey likely could be some sort “master browser” issue, or some other SMB/Samba conflict, if one has multiple OS3 My Cloud units on their local network. I only have one OS3 My Cloud and never had an issue of the OS3 single bay My Cloud not showing up under Computer when viewing the Network.


If it is a Master Browser issue and another device on the local network is already designated as the Master Browser, one can try disabling Master Browser on their OS3 single bay My Cloud. Skip to step 4 in the general directions below.
Compilation of Windows 10 Methods, Steps and Solutions

Third option: The following option was taken from this thread . It will require your router or gateway to have an option to configure the router / gateway as the “Samba Master Browser” AND will require the editing of a file on the My Cloud via SSH to change several of the SMB settings. Check your router / gateway’s administration or configuration pages to see if it has an “Samba Master Browser” option.

  1. Access the router / gateway’s administration or configuration page.
  2. Enable “Samba Master Browser” on router / gateway.
  3. Reboot router/ gateway.
  4. Using SSH and WinSCP or similar program log into the My Cloud.
  5. Navigate to “/root/etc/samba/”
  6. Optional: Create backup of “smb-global.conf” file.
  7. Open / edit the “smb-global.conf” file and edit the following lines to match:
    local master = no
    domain master = no
    preferred master = no
    os level = 0
  8. Save the changes, exit SSH, reboot the My Cloud.


Thanks for the reply. I believe I had seen the thread you referenced before - - - and I have tried all those tips except the SSH editing on the smb-global.conf file.

Honestly; I am not too bothered by this - - > as the workarounds are simple; and my NAS boxes are only online sporadically. And this is an OS/3 specific issue - → Never saw a problem when I had a box on OS/5.

I would try the SSH editing now. . . .except for the minute everything is working as it should.
Go figure. Early yesterday; I started out with no WD OS3 devices running. . . .and over the course of the day - - - I had three running. Behavior was as it should be.

Because of this thread, I played around with things. With various devices going off network and back on (both computers and NAS boxes) everything appeared as it should after a file explorer refresh (pressing the refresh button once, maybe twice). My system is a bit more complicated than most; as I was running with 2 NAS boxes one network; and 1 NAS on a second network (with a separate router).

The one odd thing I did note ; PC’s did appear/disappear off of the “Network computer” list immediately as they went online/offline. In addition; the NAS units would disappear from the “network computer” list if the computer switched to a different network. HOWEVER; if a network with a NAS had the NAS removed; the “network computer” list would still show that NAS (when the PC was on that network) UNTIL the router was rebooted. (so clearly; the routers were the master browsers; and were keeping the NAS boxes in the list even when the NAS was offline)

For giggles; I went in and disabled SMB1 on two computers. The NAS boxes immediately disappeared from the relevant PC’s. . . and reappeared when SMB1 was reenabled on those PC’s.

Odd behavior.
I will make a note to look at this again next week.

(I have a shiny new NAS that was delivered while I was typing. . . . . I like toys :slight_smile: )

Do NOT enable SMB1, keep it disabled!

Windows 10/11: Start up Windows Services and enable two services:

– Function Discovery Provider Host
– Function Discovery Resource Publication

For both services set startup type to Automatic (Delayed Start).

Mount My Cloud gen1 drive via File Explorer > Map network drive:
\\WDMYCLOUD\Public or custom static IP \\192.168.1.x\Public
Tick >Reconnect at sign-in< option then click >Finish<

SSH into WDMC gen1 and edit smb.conf to add two lines under section [global]:

nano /etc/samba/smb.conf

	server min protocol = SMB2
	server schannel = yes

Restart service:

service samba restart

The key is the drive mapping that you reference.

However, that does NOT solve the issues described in thread. Mapping is one of the several work-arounds.

This was my solution. I was able to easily navigate to the IP address (as I gave it a static) and once I had it up in explorer, I was able to map my shares as needed. Not exactly how I wanted it, but it works none-the-less and is less of a headache to try and do all that other ssh stuff. :man_shrugging:t3: