18.5MB transfer speeds on gigabit LAN


thanks for spelling it all out like that. being on the same network I didnt imagine there was a whole second directory structure inaccessible to the app (or that the drive would be accessed differently). I am able to transfer to the Public folder at ~115MB and thats great!..but not all that great. I would like to use this drive from home and while away without having to duplicate all of the date between both directory sets. I will have to re-evaluate my timeline for a better solution, but in the meantime this will work out fine enough. Thanks again!


From my reading of the forums, the ‘public’ directory function was not on the original version of the MCH. It was bolted on later after customers complained, thinking they were purchasing a NAS device (which is what I thought I was getting).

Just checking that your aware that the “public” directory is not accessible via home.mycloud.com or via the MyCloud Home app. So if you’re wanting to access the “public” directory on the MCH remotely, you’ll need to try something different.

Edit… I just re-read your post, it looks like you’re aware of this limitation. The problem is made more apparent when copying files from one file system to the other. Has to be done via a different computer, and at the ridiculously slow transfer rate.

asco & Kung… Thanks for taking the time to provide insightful replies to my questions. Ultimately I decided to just return the product, and that wasn’t easy. I bought it direct from WD for $189, so in a Chat session I asked for an RMA to return it for a refund. I got a response from WD Support saying that the Warranty provided does not allow for returns with a refund. I was shocked, as this violates California “cooling off period” laws as far as I know. I reengaged with the Chat, and got an RMA from them, then UPS emailed me a shipping label that was free of charge. Of course, we’ll see if it all works.

asco, relative to the suggestions you made on how to use the unit as a regular NAS, thanks for that insight. Too bad WD doesn’t have that info anywhere that I could find on their website–I might have tried to use it that way. But I was already PO’ed with them to the point that I was going to return it, so that’s the course I took. My LAN operates on a NetGear WiFi6 mesh router I just bought, on a subnet underneath a ■■■■■■ AT&T modem/router (3800). All wired devices are connected to a 1Gb/s switch, and all wireless are connected to the NetGear subnet. The NetGear runs the DHCP for the subnet. I get 112 MB/s large file transfer rates using two gaming computers with SSDs and hardwired to the same switch, using W10 drag and drop. With one machine connected to WiFi @ 5GHz, I get 35MB/s, a surprising dissapointment. Going to my ancient Buffalo hard wired I get about 50MB/s. Perhaps this is all I should expect…Jack

A new Pocket’s NAS called RAVPOWER

Find the drive IP on your router and type (double \)your drive IP\ in an explorer window and it should open and show you the public folder. You won’t be able to see the cloud folders and you can’t see the public from the app

Thanks man; i’ve tried many times to access that folders through web browser, nothing. Because my router don’t show ip address of wired devices, i didn’t know my ip until i bought my new router. after knowing ip, i just tried to web browser. You make my live better guy, Thanks again

Hi, guys.

Short answer would be - re-plug the LAN cable of device.

Long answer is here, I would continue in that topic.

1 Like

Hi denixx.

Thanks for share that.
Of course, this is not a solution, is a temporary fix to this bug. But, I am sure it will help to tolerate better this device.
In my case, I just returned it and I am waiting for a My Cloud EX2 Ultra. I am one of many that though this was a NAS ¬¬

I think i have some problem.

Do you use VPN. In my case, this problem happened when i connect to VPN. Any one have simillar issue?

Hi guys,

I just got my router replaced by my ISP to a new model. Now the transfer speed to MCH is around 120MB/s, where before was 18MB/s.
I had multiple tickets with WD on this topic and they had explanations for everything (indexing and so) and now… was it the router all along? But I wasn’t alone as this forum shows.

Screenshot of a 2.7GB ubuntu iso. Also Radarr just copied a movie in 5 seconds and could see “960mbps Send” in Task Manager (before, it was 2 minutes)

I’m so happy. I don’t know if it’s the new router or an update from WD?

Still got that speed antonio1475? I only get that speed if I pull out my network cable for some time… Very special problem. WD should fix this now! 18.6 MB/s, pull the cable out for a few minutes and then back again I have 110-120MB/s with ASUS RT-AC66u.

1 Like

Yup. No matter if I use “My Cloud (Z:)” or “My Cloud” (network drive, \My-PC\My Cloud_xxx).
I’m switching providers on Thursday (new router, new network) so we’ll see if this wonder stays…

I wanted to add that I had to buy a new router that goes after the ISP one (Honor 3, then a Huawei AX3, basically the same) and now the speeds are back to 18MB/s 99% of the time, no matter if I use a TP-Link Gigabit switch or not).

If I play around (a lot) switching cables and restarting random devices in the chain, I get >100MB/s for a while, then back to 18MB/s.

This is an unexplainable shitshow… so disappointed in WD. :angry:

I have had the same dreary 18mbps transfer speed. Turns out I had Hyper-V installed and it messed with my connections on Windows. Uninstalled Hyper-V and boom! ~75mbps

Hyper-V is probably not the reason. The limit lies with the WD server authentication for the private space that is online shareable. There is throttle limit when sustained transfer is initiated. Do CrystalDiskMark tests (choose folder test as target) over a few days and you will see the sustainable speed over time.

I am going to open again the topic, after the last update i have this speeds


I am back to slow speeds, and this is worse if i have a lot of small files to transfer, gets extremely slow

  • Good job WD. The development team deserve some appreciation on the recent effort on firmware improvement.

Firmware 8.12.0-178 has a Dashboard enabled SMB share that is the new password shareable SMB volume as well as online shareable and linkable space, so the old limitation has been removed. The speed is reasonable for an entry level NAS (100 MB/s for read write large files).

This new firmware also allows access to the MCH without the previous requirement of online internet access.

My Cloud Home Firmware 8.12.0–178 Release
Version: 8.12.0–178
Release Date: 11/14/2022

Half way close to a better NAS I would say: I noticed that files previously created with WD Discovery (either Mac or Windows) can be deleted but can’t be read (nor moved) with this SMB implementation…

Curious i have only 10mb/s rate but at least i can see photos without having the explorer crashed

Except for some photos that i can’t see