160gb drive showing as only 3.52gb

Western Digital ‘Caviar Blue’ 160gb drive


win 7

Jumper set to cable select  also tried slave

have tried formating (quick and full) in both fat32 and NTFS

This is a brand new drive that has neve been used. Decided to use it for storage only. Plugged it into an external enclosure that I know works. The HDD only shows up as 3.52gb

I can load files up to 3.52gb and the drive functions perfectly, appart from the fact it is 156.5gb missing

Any thoughts ?

Your HDD apparently only has one partition with the size of 3.52GiB.

Windows is horrible when it comes to partitioning, so I recommend downloading the latest GParted LiveCD (free and open source) and boot it. Either delete the small partition and create a new or resize the preexisting one. It has a graphical user interface, so it is pretty straight forward. Just make sure to select the right drive!

try easeus partition master home edition :slight_smile:

That could be a bit out of my capabilities - I would probably wipe out my C drive. A gret pity to waste it, think I paid about £40 for it  about five years ago…

Why would it come with a patition on it?  seriously this is brand new and was never plugged in before last night.

HDDs tend to be preformatted, even sometimes with a partition or even a filesystem.

Here’s how you can make super sure, not do do anything wrong:

  1. Grab GParted LiveCD and either install it on a USB Stick or burn it on a CD (I recommend ImgBurn)

  2. Turn off your computer and disconnect ALL DRIVES (and memory cards/USB sticks) except the one with that small partition

  3. Boot the LiveCD/LiveUSB

  4. Run GParted and properly set the partition size. It is pretty straight forward!

Step #2 to ensures that you don’t accidentally kill the data of another drive.

thanks for all the advice and pointers - I found something on windows 7 (disk management) that allowed me to repartition the drive in just a few minutes. Drive is now working perfectly.