10 days of misery

I bought a WD MyCloudEx2 10 days ago and feel it’s my duty as a consumer to describe the misery I’ve experienced attempting to use it with a MacBook air running Yosemite 10.10.2.  Plot spoiler: *Do not buy this device*.  I read similar reviews but like a clown chose to ignore them.

First I tried to copy my iTunes library, after perhaps 3 Gig had uploaded, it just stopped.  No explanation, no indication of what’s happening.  I let it sit for ~2 hours before abandoning hope.  Next I tried copying a few folders at a time, which kindof worked except if I tried to copy more than say 3 Gig, in which case it would usually stop.  I would even leave it in the morning, go to work and come back to find it had not progressed, so it had plenty of time to sort its act out.  After blowing a week of my free time getting my iTunes library transferred all seemed well; iTunes was reading the files from the NAS no worries except for 3 second delays between tracks.

Next I did a time machine backup, which worked first time, and subsequent ones mostly ran with perhaps only 8 or 10 fails.

Two days later, iTunes tells me “Nuh-uh buddy, can’t read the files” even though the admin interface tells me everything is 100% healthy.

A day after that I get a message from time machine saying something like “Validation of your time machine backup reveals it’s a steaming pile of **bleep** heaped on top of an even bigger pile of **bleep** that’s been left in the summer sun to ferment.  You gotta delete it and do a full backup, oh yeah and you’ve lost your backup history”.

My next complaint is the upload “browser”.  For a mass storage device, it’s astounding there’s not even a folder file count or folder size.  With that, I could at least have some way of comparing with the source to know what folders had transferred okay.  But no.  Easiest way I figure is delete the folders and re-upload.  I select the suspect folders, attempt to delete them but the “browser” tells me “You can’t select multiple folders”.  Fantastic, I get a workout for my mouse finger by doing one-by-one-by-one “delete”, “yes I’m sure” “delete”, “yes I’m sure” “delete”, “yes I’m sure”.

I am 99% certain that the makers of this device have not plugged it into their own networks for personal use, because if they had they’d say “We can’t sell this - it’s entirely unfit for purpose”.

Summary: If you have a lazy 500 bucks, I suggest going to the local casino and putting it all on 21 black at the roulette wheel.  Your chances of joy with that option are higher than if you purchase a WD Cloud EX2 “NAS”.

How can I have any faith in this device considering the last 10 days?

One postive feature is that it hasn’t caught fire yet.

p.s. I have the latest firmware, and my Wifi is excellent.

This is not the 1st topic on this forum that people are complaining and returning the product.

I think WD should take this seriously and improve the products…like some firmware updates…i’m just sain’ ( last update was 5 months ago )

buy a Synology and enjoy it

How are you transfering files?

Via USB or by PC?

I just transfered 36gb in less then 10 minutes.

It was last week that I sell my EX2 in E-Bay and buy a DS214Play from Amazon (Germany)

check my last topic:


 copy from USB3 to my NAS Drive: 67MB/s

So this time, I did my research and ended up with a similar call as the other guy who posted.  Bought a nice shiney Synology DS214+, took the drives over from the WD MyCloud EX2 so lost ~3 hundy at the end of the day.  Long story short, it’s better in every way.  In my opinion.

Because I’m a curious type of guy, I plugged an ethernet cable into the empty cardboard box that the Synology NAS came in.  Now I don’t have any hard metrics to back this up, but just going by feel (and this is just my opinion), the empty Synology cardboard box is giving comparable performance stats to the WD MyCloud Ex2.  In fact, it’s given no errors so far, so arguably better.


To be fair, WD support proactively contacted me after seeing my rant and offered support so points for that.


you select the best way!

they contact me too but it was too late :smileyvery-happy:

I’m really happy with Synology

After 6 months of low EX2 performance and unwanted wdmc files contaminating my filesystem
I replaced it with a Synology DS713+.

Now performance is good,
and the only files i have on it are the ones I put there myself.

Why WD does nothing about the issues after 6+ months of complaints
and suggestions from many users is beyond comprehension.
The don’t even comment on this.

//Anders J