1 TB WD Drive not recognized

I have 1 TD External Drive which was working fine and than suddenly a fews days back it is not recognized … I have Installed all the possible drivers but still i get the error that " WD SES USB DRIVERS NO DRIVERS FOUND " .

I have tried to connect it on different PC’s Nd Laptops , tried Different USB 3.0 Cables but none of them worked for me. 

I m using Windows 7 Ultimate Edition . details of my wd drives are as follows … 

WD10TMVW - 11ZSMS1  1.0TB


DATE: 27-FRB-2011 P



5VDC - 0.60A

S/N WX31AA087985.

I m dam serious about the issue and to resolve this issue as i have my life data in it . further more posting some pic for further clarifications . 

Pic 1 :

This is the first error i get when i plug in the USB 3.0 Cable .

wd ses drivers not found.jpg

PIC 2 :

This is what i get in Device manager

PIC 3 

and this is what i get in Device Management  :

I hOpe to get some positive Replies which would lead me to help in solving the issue . 


try updating the firmware and then download the SES driver package

i tried to update the firmware but i m getting this error … i i disconnectd all the usb drives and than reconnect the wd drive but … 

wd 4.jpg

The drive is not working and needs to be replaced

what about my data in the HD … ??