1 TB Passport Ultra now corrupted

It’s about 18 months old. Yesterday it worked. Today, when I plugged it in, I get the message “E:\ is not accessible. The file or directory is corrupted and unreadable”

I get the same message on a different computer. I also have several other Passports - they work fine.

I ran backups every night to a different drive, but it looks like some directories weren’t backed up (maybe user error). Can I recover any files from this disk?

Hi davidwright2000,

You can try to use chkdsk /f h command (here, “h” is a connected external drive) to repair the data of corrupted drive without data loss. However, there are also some data recovery software available to recover the corrupted data from the drive.

Well, that’s why I posted the question. Can you name a specific tool that is useful? I searched and installed several, but they all wanted me to buy something

Data Recovery is almost a chargeable service but here are some methods mentioned in below article for data recovery as referred by the Western Digital: