1 TB HDD shows as 32MB

Hi everybody. I got a huge problem with my HDD.

the model is WD1002FAEX.

I had to change motherboard switching from a  P8P67-M PRO to a P8 H61 R2.0. Both ASUS.

When the system booted up, it recognized my 500GB primary HDD, but told me the system couldn’t access the other drive.

I went to the BIOS and there too the second HDD is shown as 0.0 GB size (aka 32 MB, as shown in windows)

I have important data in it, and i have no idea how to restore it.

I tried programs like HDD recovery (doesn recognize my drives) and Seatools (RAM error when compuer runs with it).

Obviously i ran the WD utility to check my HDD integrity and it says my 32 MB HDD is quite fine…figures.

Upgraded the Bios…changed from IDE to AHCI…formatted win7…nothing helps

Any suggestion guys?

Thank you

It appears that your Asus BIOS might have the Gigabyte disease.

See Q2:
http://www.users.on.net/~fzabkar/HDD/HDD_Capacity_FAQ.html

Well, there is an improvement.

Thanks to your link  i learned there is nother program falled Hdat2. That actually worked, and now the Bios recognize 1000GB of space on my HDD

Sadly windows, under Control Panel–administrative tools—computer management—disk management

still tell me 32 MB RAW. Even if this time the Area is a lot bigger than before using the program.

Still no access to my HDD. File system not accessible, asking to format.

OK.

Thanks to your link…i ended up here.

http://community.wd.com/t5/Desktop-Mobile-Drives/1-5-tb-black-is-now-reading-500-gb/m-p/241688

that led me to this program

http://dmde.com/download.html

And…ITS FIXEEEEEEEED

Just for the record in case some1 may have the same problem, this is what i did to fix it.

  1. I downloaded HDAT2 (since the other 2 of the “Trinity” didn’t work).

  2. I ran it, and obviously it gave me error (Abort, Retry, Fail…i chose Fail…the gods must have guided my hand)

  3. The program proceeded and i removed the hateful HPA ( Host Protected Area )

I rebooted and noticed BIOS recognized my HDD as 1000GB instead of 0.0. YAY…windows didn’t tho, so here’s what i did then

  1. I downloaded DMDE (very intuitive and easy to use)

  2. I recovered some lost data just by clicking it, and so i understood the data was safe and sound and could be recovered.

  3. I DELETED the 32 MB FAT32 partition.

  4. I then used the command “Insert the Partition (Undelete)” on both my greyed out partitions (those that had disappeared)

  5. Reboot and here i am, with C:, D:\ E:, F:…AND ALL MY FILES BACK.

Thank you fzabkar for pointing me to that guide. It had ALL i needed to make this work.