1 disk shows as 2 disks


#1

Hi, I have a 3TB RED NASware WD30EFRX drive recovered from a Synology DS412+ 4-bay NAS.
When I connect it to my laptop (Windows 10 Professional, 64 bits) (SATA to USB3 adapter), it comes up as 2 disks in Windows “Disk Management”. The two disks are of 2TB and 750GB. These are not partitions on the same disk; they appear as two separate independent disks.
Each of them, I can initialize, partition, format, etc without any problems. However, I can’t seem to be able to “join” them into a large 3TB disk.
The BIOS and all the drivers are up-to-date; the laptop is a Toshiba P50t, the CPU is INTEL i7 and has 16GB of RAM. I also tried with a Lenovo 3000 and got the same result.
Does anybody know why this could be so? and how to get it appear as one 3TB disk?
I have already tried WD Data Lifeguard, but they provide no option to undo the split (I don’t know what else to call it.)
Thanks for any advice.

++++++++

It turned out that the 2TB limitation was on the SATA-to-USB3 adapter I was using (go figure!).
I changed the adapter and the drive shows as a whole 3TB disk, as it should.
Thanks to all who replied.
(I’m not sure how to close this “case” - can’t find any “closed” button to click in the forum)


#2

Hello,

I recommend you to connect the drive directly to the SATA port of a desktop computer to determine if you are having issues with the WD hard drive or the USB/SATA connector.