1.5Tb WD Elements external USB desktop hard drive not being detected by WD TV Live SMP


I’m running firmware  1.05.18.

I had only had the WD TV Live SMP half an hour and I was having problems with it… :cry:

I attached a 1.5Tb Elements drive (NTFS) with 320Gb of media on it and the WD TV Live found it fine and built a media library.

I proceeded to play a .mkv file and the file froze halfway through (I had problems playing this file on another media player which is why I decided to buy the WD TV Live).

I tried to “go back”, “stop” etc but the player had frozen. My only option was to turn the WD TV Live off.

When I switched the WD TV Live back on it would not recognise the 1.5Tb Elements drive.

Using my PC (Windows XP) I then moved all the data onto another drive and reformatted the 1.5Tb Elements drive using the procedure here.

As advised here.

Once the drive had reformatted I re-attached it to the WD TV Live and the drive was recognised.

Great I thought!

I ejected the drive as recommended before removing it.

I then added all 320Gb data back onto the 1.5Tb Elements drive and re-attached it to the WD TV Live… but now it doesn’t see the drive again!!!  :angry:

I re-attached the 1.5Tb Elements drive back to the PC and deleted the WD TV Live folder but the drive was still not recognised when re-attched to the WD TV Live.

I have a 1Tb WD Elements drive which is found fine by the WD TV Live.

Please advise!!!


PS. BTW, PLEASE WD - build in an “eject all hard drive routine” into your “power off” sequence. It’s hard to remember to eject and external hard drive every time you switch off the device! 

1 Like

By any chance, if you remove the movies again and reconnect the drive to the WD TV, the drive is detected again?