1.5tb Passport won't copy large files

I have a 1.5TB passport drive that will not complete large file transfers.  I am trying to copy a 12.72GB file to it and it gets to 25mb and gets no farther.  I have tried it with another 15.23TB file and it does about the same thing.  Drivers are up to date intel drivers, laptop is a Clevo P157SM.

What I have tried so far -

  1. another USB port - no fix
  2. removed the driver from device manager, reboot, reinstall driver - no fix
  3. Terracopy/copy - no fix
  4. Scan disk finds no errors
  5. smaller files copy without an issue
  6. other usb 3.0 devices on the different ports and copy to them - no problems.

Any suggestions?  It is only with the passport drive. :frowning:

Forgot to mention it is formated NTFS.

Here are some things you need to consider. 

  1. Can those files be copied to another drive? If not, then there might be some corruption in those files. 
  2. Have you tried repartitioning and reformatting the drive?  There may be something off with the partition table.  You would need to make sure whatever files you have on the drive are backed up.
  3. What do you mean by it (the transfer?) just stops there?  Does the drive stop working? Does it disappear off the laptop?  How long did you leave it sit, before you stopped the operation?
  4. What Passport do you have (Model number)?
  5. Are you sure you don’t need to get a power booster cable for the drive?  You would need to purchase one. You might be able to get one through Support.