software doesnt restore to proper directory

I reformatted my Vaio laptop (windows7) and am trying to retrieve my files from My Passport using smartware that came with the drive. I tried the backup using “some files” but it puts the backup into a folder at the root directory in a folder it created with the name of my computer, Vaio. So I tried to selectively restore just the Pictures folder and specified my C:\users\name\pictures and it restored it to C:\users\name\Vaio\C\Users\Owner\Pictures. What am I doing wrong. When I called WD, the tech was clueless.

Also, I would like to update my software as there are other glitches like trying to open certain directories and it won’t give me access saying I don’t have proper permissions and sometimes opening directories takes forever. I have heard that if I update my software that it will not be able to restore the old backups with it? If that is the case, WD is the most pathetic software development company I have experienced and will look to other hardware for future purchases.

Hi Even,

Please check your private message.