1.06.16 and TVersity 1.9.7 Bug

The new firmware doesn’t work with TVersity 1.9.7 - I see users reporting the same issue on TVersity forum.

TVersity reports Error - Could not execute SQL statement, reason: unrecognized token: "" and you get “There is no media in the current folder” on the WDTV Live.

Yep…   It appears to be a TVersity limitation.  

All other DLNA servers I’ve tested against support that new token with no issues.

There is now a reported fix for the problem over in the Tversity forum- http://forums.tversity.com/viewtopic.php?f=7&t=65812&st=0&sk=t&sd=a&start=15

Can someone please tell me what the reported fix is? The TVsersity board has been taken down and is not accessible. Thanks.

In the Tversity profiles.xml file, locate the WDTVLive profile and change the contentDirectory entry to-

<contentDirectory audio=“0\Music” photo=“0\Photo” video=“0\Movie” />

The profiles.xml file is in the Tversity install directory.

Thanks, I’ll give it a try.

Sorry, I made the change, saved it, restarted TVersity, but it still just tells me there’s no media in the folder - guess it’s back to a previous firmware version.

It works for me. So please post the contentDirectory entry you now have to see if there is any difference.

Also look in th Tversity log to see if there are any errors.

I’m going to have to do it tomorrow - thanks for all your help.

Here’s the content directory entry:

       

Also, I checked the log and there’s nothing there.

Thanks

I can only find the string <!-- Use 1, 2, 3 as identifiers for audio, images, video since some players may require for binding to the remote --> in 2 places in my profiles.xml file. Neither relate to the WDTVLive profile.

In my profiles.xml the WDTVLive entry starts with-

  

 <profile id=“AFF1181A-E47F-4c36-AB1D-68C00E71C096”> <!-- This profile has to come after the samsung -->
        <friendlyName>WDTVLive</friendlyName>
        Western Digital
        WDTVLive
  
  

       

       
       

        <!-- The container identifier media players of this profile expect
        -->
        <contentDirectory audio=“0\Music” photo=“0\Photo” video=“0\Movie” />

       

I made those latest changes, but to no avail - it still doesn’t work. Do you want me to email you my profiles file to see if there are any differences to yours?

Easier for me to post my profiles.xml to pastebin.com. Here is the link- http://pastebin.com/jVtq38ee

You should be able to download this file and try it.

PS. I have forgotten to ask, but what media type(s) are you having problems with? Is it Music, Photo or Movie?

PPS. Your are restarting your WDTVLive after you make these changes and reboot your Tversity machine?

I tried your profile file but it still doesn’t work. I still get the message ‘No media in folder’ for all types, audio, video and photos. Yes, I’m rebooting the device and reatrting TVsersity after wach change. I can watch all 3 types of media using Playon, Twonky etc so it doesn’t appear to be a network or sharing issue and if I revert back to the previous WD firmware release it works fine. Also, if if I click on the folder in TVerity / Library on my PC and then Open Item I see all the content. It’s mystery. It’s actually no big deal to go back a release, it’s just the nag screen telling me that there’s new firmware available that’s annoying.

Well yes that is a mystery. Why you have a problem and I don’t with the same profiles.xml file, I cannot explain. Maybe just uninstall Tversity and then reinstall it.

Personally I gave up on Tversity a long time ago, it was was just too flaky and well did not provide any significant feature benefit over my trusty Twonky. Biggest being Tversity cannot run on a NAS.

So again sorry that I have not been able to help you.

I’ve recently built a HTPC based on a DELL ZINO and have tried using WMC instead of TVersity, Twonky etc - but somehow it doesn’t have the right feel to it, and there’s also a lot of file types it can’t play without extensive modifications and add ons. I’ve also installed BOXEE and have so far been reasonably impressed with that, although once again there are file restrictions - in fact (sad to say) the only software that appears to play virtually everything is TVersity.

It works fine. Thanks:

In the WDTVLive profile replace this line:

with this one:

In my case profile.xml was in: C:\ProgramData\TVersity\Media Server

I also tried it but it didn’t work.

Restarted TVersity, WDTV - no changes.

!!! UNTIL I made a right click on the Tray-Icon of TVersity and clicked on “Restart sharing”  !!!

I really don’t know why a restart of TVersity doesn’t work - and “Restart sharing” does it… …wired!

Hope this helps…