Reply
Visitor
davedags
Posts: 5
Registered: ‎08-16-2013
0

Win 8 External USB Drives Not Seen in Windows Share

Hi all - I am new to forum and tried to search for answers.  Apologies if this is in the wrong place.    I have a comp sci background and have been working in the industry for 10 years so I feel like I have a good grasp on how to setup the wd live and sharing/etc.    My setup is my PC has a user called "share"  that i use as a dedicated login on the wdlive to access the pc share.    I have specified numerous folders as "shareable" and set permissions to everyone.     In the past everything worked perfectly - i'd choose network shares, would see my PC Home - then in clicking in I'd see all top level folders that i marked as shared.     My 2 USB externally connected drives to my pc are mapped to a physical letter, marked as shared as well AND they too showed up perfectly.  I loved this because I can download directly to my external drives connected to my PC, but then access it straight from the wd live.

 

Recently I upgraded to win 8 from windows vista  and also there have been probably 2 firmware upgrades on the wd live.  I cannot remember when the problem started (probably windows 8), but now no matter what I try it NEVER sees the external drives.   the wdlive sees everythign else - the Users -> share -> all folders are accessible since i made the share users public folders all shareable.   This works so sharing seems fine in general.

 

Anyone have any advice why it no longer sees my usb drives connected to my pc??  Now i am forced to use up my pc's disk space and would much rather the older setup.

 

Sorry for the long  post, but wondering if anyone has any ideas or has experienced this.

Staff
Ichigo
Posts: 2,557
Registered: ‎02-28-2013
0

Re: Win 8 External USB Drives Not Seen in Windows Share

Hello and welcome, 

 

Review the steps on the following link to see if it helps. 

 

How to share a folder in Windows that can be viewed with the WD TV Live, Live Streaming, Live Hub, o... 

Click the Kudos star on the left to say thank you for helpful posts. And be sure to come back to click the 'Accept as Solution' button for the post that solved your issue. This may help someone else.
Advisor
beau420
Posts: 17
Registered: ‎07-14-2013
0

Re: Win 8 External USB Drives Not Seen in Windows Share

Since moving to Windows 8, are your USB connected drives appearing in Windows like they did before in Windows Vista?

 

Open My Computer and right click on the external USB drive and click on the Share tab, share the drive letter, give the Share user access, click under the permissions tab and again, give the Share user access.

 

To confirm what is being shared, right click on My Computer and chose Manage to open the computer management window.  In here, on the left click on Shared Folders and expand, and below that select Shares.  It should show all of your shared folders that should be visible from the WDTV.

Visitor
davedags
Posts: 5
Registered: ‎08-16-2013
0

Re: Win 8 External USB Drives Not Seen in Windows Share

Hi - thanks for your post.  I have done everything you suggested before and have verified again.   The only step I never knew about was clicking the "manage" on My Computer.  When i do, the Shared folders -> Shares does list the 2 external drives.  I assigned them letters W and Y and I actually see the following:

 

W

W$

Y

Y$

 

the $ ones say they are for adminstrative purposes.  The other ones i can add users and they both show "Everyone" having full access.  I even went and added the Share user specifically, even though Everyone should cover that.  

 

So everything checks out but for some reason they still don't show up in wd live when i select my home network share

Visitor
davedags
Posts: 5
Registered: ‎08-16-2013
0

Re: Win 8 External USB Drives Not Seen in Windows Share

One more thing.  In the Computer Management window, I see a Users Folder that is yellow.  The 2 external drives are maybe a grey color.    The only folder that shows up in my wdlive tv when i connect to my home network is the Users folder.   The external drives W and Y, while they both show up as being shared in cmputer management, do NOT ever show up wdlive.   Before windows 8 (or a firmware upgrade), W and Y would appear at the top level if i shared them explicitly.  In the past i shared a folder within one of the drives (i.e. W:/Music) and that would show up.

 

Really am scratching my head on this one as everything appears fine except for wdlive recogizinging the shared folders.

 

Only other difference i see is the description of W and Y are  Default Share, whereas the Users one doesnt have a descriptino and of course is on the pc's hard drive (C:\Users).

 

Any other suggestions??

Visitor
davedags
Posts: 5
Registered: ‎08-16-2013
0

Re: Win 8 External USB Drives Not Seen in Windows Share

Sorry - last bit of info. i shared random folders on the local C: drive and everyone one showed up on wd live.

 

c:/code

c:/Users/share/Videos

 

And then i tried sharing a folder WITHIN the external drive connected to my PC (instead of just the whole drive) so

 

w:/Movies

 

And this one does NOT show up.  In the Computer Management Window, w:/movies shows up exactly as c:/code above, all the sharing properties are the same.    

 

So unless I somehow changed some other security setting on windows 8, this seems to be a bug with the wdlive as everything is setup as it should be according to standard "sharing" procedures. 

Visitor
davedags
Posts: 5
Registered: ‎08-16-2013
0

Re: Win 8 External USB Drives Not Seen in Windows Share

at this point im assuming it's not wdlive's issue as if i go back to win7 im good.  must be some security policy thing on win 8. i read a few articles about external drives not be recognized on network shares on windows 8 and they had to mess with local security policies to get it to work. 

 

 

weak :smileysad:

Advisor
beau420
Posts: 17
Registered: ‎07-14-2013
0

Re: Win 8 External USB Drives Not Seen in Windows Share

Maybe reformat the drive.

 

Works fine for me.  I just tried plugging in a USB stick, sharing it...adding everyone group.  Then on the WDTV, I select movies, and Network Shares, select Windows Shares, select my computer's name, click ok and it sees the shares.

 

The drive I shared was formated as a Fat32 drive, so there were no NTFS permissions to worry about...then again, there are limitations to Fat32.  I would format the drive and start from scratch, but if it is loaded full of media, you might not want to do that.

 

Try doing the same thing with a USB flash drive/USB stick and see if the WDTV sees the share....if it works with a stick but not your hard drive, then the problem is the hard drive/permissions on th drive.

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2013 Western Digital Corporation, All rights reserved. | Trademarks | Privacy | Terms of Service | Terms of Use | Copyright | Contact WD