MKV files Freeze SMP

Status: Investigating
by on ‎03-13-2012 10:18 AM

I've recently started using Handbrake 0.9.6 to make my MKV files as I have for the last 2 years with version 0.9.5. My problem is that the WDTV SMP freezes about 20-30 seconds after the movie starts to play these new MKV files and have to perform a hard reset or the player won't play any other files. I've read thru the forum and see that others have had similiar issues. I've had this problem using firmware versions 1.06.15 & 1.07.15. 

I don't have any problems watching these MKV files using the WDTV Live or WDTV Live Plus so the problem as we all know is with the WDTV SMP. I've included the MediaInfo of 3 files that the SMP can't play. 

 

I'm hoping that this problem can be resolved ASAP.

 <?xml version="1.0" encoding="UTF-8" ?> 
- <Mediainfo version="0.7.54">
- <File>
- <track type="General">
  <Unique_ID>157771697019136716609150950092375318698 (0x76B1B93BA90C3320D024D094073BE0AA)</Unique_ID> 
  <Complete_name>C:\Users\Danny\Desktop\Our Idiot Brother\Our Idiot Brother.mkv</Complete_name> 
  <Format>Matroska</Format> 
  <Format_version>Version 2</Format_version> 
  <File_size>4.35 GiB</File_size> 
  <Duration>1h 29mn</Duration> 
  <Overall_bit_rate_mode>Variable</Overall_bit_rate_mode> 
  <Overall_bit_rate>6 924 Kbps</Overall_bit_rate> 
  <Writing_application>HandBrake 4405svn</Writing_application> 
  <Writing_library>libmkv 0.6.5</Writing_library> 
  </track>
- <track type="Video">
  <ID>1</ID> 
  <Format>AVC</Format> 
  <Format_Info>Advanced Video Codec</Format_Info> 
  <Format_profile>Main@L4.0</Format_profile> 
  <Format_settings__CABAC>Yes</Format_settings__CABAC> 
  <Format_settings__ReFrames>4 frames</Format_settings__ReFrames> 
  <Codec_ID>V_MPEG4/ISO/AVC</Codec_ID> 
  <Duration>1h 29mn</Duration> 
  <Bit_rate>5 225 Kbps</Bit_rate> 
  <Width>1 920 pixels</Width> 
  <Height>1 080 pixels</Height> 
  <Display_aspect_ratio>16:9</Display_aspect_ratio> 
  <Frame_rate_mode>Variable</Frame_rate_mode> 
  <Frame_rate>23.976 fps</Frame_rate> 
  <Color_space>YUV</Color_space> 
  <Chroma_subsampling>4:2:0</Chroma_subsampling> 
  <Bit_depth>8 bits</Bit_depth> 
  <Scan_type>Progressive</Scan_type> 
  <Bits__Pixel_Frame_>0.105</Bits__Pixel_Frame_> 
  <Stream_size>3.28 GiB (75%)</Stream_size> 
  <Writing_library>x264 core 119</Writing_library> 
  <Encoding_settings>cabac=1 / ref=2 / deblock=1:0:0 / analyse=0x1:0x111 / me=hex / subme=6 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=2 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=20.0 / qcomp=0.60 / qpmin=3 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00</Encoding_settings> 
  <Language>English</Language> 
  <Default>Yes</Default> 
  <Forced>No</Forced> 
  <Color_primaries>BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177</Color_primaries> 
  <Transfer_characteristics>BT.709-5, BT.1361</Transfer_characteristics> 
  <Matrix_coefficients>BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177</Matrix_coefficients> 
  </track>
- <track type="Audio">
  <ID>2</ID> 
  <Format>DTS</Format> 
  <Format_Info>Digital Theater Systems</Format_Info> 
  <Format_profile>MA / Core</Format_profile> 
  <Codec_ID>A_DTS</Codec_ID> 
  <Duration>1h 29mn</Duration> 
  <Bit_rate_mode>Variable</Bit_rate_mode> 
  <Bit_rate>1 561 Kbps / 1 510 Kbps</Bit_rate> 
  <Channel_s_>6 channels</Channel_s_> 
  <Channel_positions>Front: L C R, Side: L R, LFE</Channel_positions> 
  <Sampling_rate>48.0 KHz</Sampling_rate> 
  <Bit_depth>24 bits</Bit_depth> 
  <Compression_mode>Lossless / Lossy</Compression_mode> 
  <Default>Yes</Default> 
  <Forced>No</Forced> 
  </track>
  </File>
  </Mediainfo>


<?xml version="1.0" encoding="UTF-8" ?> 
- <Mediainfo version="0.7.54">
- <File>
- <track type="General">
  <Unique_ID>15965955038606242552177680621004147328 (0xC02EE5BE95C690B9CA1A30F0B4C4A80)</Unique_ID> 
  <Complete_name>C:\Users\Danny\Desktop\The Matrix\The Matrix.mkv</Complete_name> 
  <Format>Matroska</Format> 
  <Format_version>Version 2</Format_version> 
  <File_size>7.40 GiB</File_size> 
  <Duration>2h 16mn</Duration> 
  <Overall_bit_rate>7 770 Kbps</Overall_bit_rate> 
  <Writing_application>HandBrake 4445svn</Writing_application> 
  <Writing_library>libmkv 0.6.5</Writing_library> 
  </track>
- <track type="Video">
  <ID>1</ID> 
  <Format>AVC</Format> 
  <Format_Info>Advanced Video Codec</Format_Info> 
  <Format_profile>Main@L4.0</Format_profile> 
  <Format_settings__CABAC>Yes</Format_settings__CABAC> 
  <Format_settings__ReFrames>4 frames</Format_settings__ReFrames> 
  <Codec_ID>V_MPEG4/ISO/AVC</Codec_ID> 
  <Duration>2h 16mn</Duration> 
  <Bit_rate>6 975 Kbps</Bit_rate> 
  <Width>1 920 pixels</Width> 
  <Height>796 pixels</Height> 
  <Display_aspect_ratio>2.40:1</Display_aspect_ratio> 
  <Frame_rate_mode>Variable</Frame_rate_mode> 
  <Frame_rate>23.976 fps</Frame_rate> 
  <Color_space>YUV</Color_space> 
  <Chroma_subsampling>4:2:0</Chroma_subsampling> 
  <Bit_depth>8 bits</Bit_depth> 
  <Scan_type>Progressive</Scan_type> 
  <Bits__Pixel_Frame_>0.190</Bits__Pixel_Frame_> 
  <Stream_size>6.64 GiB (90%)</Stream_size> 
  <Writing_library>x264 core 120</Writing_library> 
  <Encoding_settings>cabac=1 / ref=1 / deblock=1:0:0 / analyse=0x1:0x111 / me=hex / subme=2 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=1 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=10 / rc=crf / mbtree=1 / crf=19.0 / qcomp=0.60 / qpmin=3 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00</Encoding_settings> 
  <Language>English</Language> 
  <Default>Yes</Default> 
  <Forced>No</Forced> 
  <Color_primaries>BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177</Color_primaries> 
  <Transfer_characteristics>BT.709-5, BT.1361</Transfer_characteristics> 
  <Matrix_coefficients>BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177</Matrix_coefficients> 
  </track>
- <track type="Audio">
  <ID>2</ID> 
  <Format>AC-3</Format> 
  <Format_Info>Audio Coding 3</Format_Info> 
  <Mode_extension>CM (complete main)</Mode_extension> 
  <Codec_ID>A_AC3</Codec_ID> 
  <Duration>2h 16mn</Duration> 
  <Bit_rate_mode>Constant</Bit_rate_mode> 
  <Bit_rate>640 Kbps</Bit_rate> 
  <Channel_s_>6 channels</Channel_s_> 
  <Channel_positions>Front: L C R, Side: L R, LFE</Channel_positions> 
  <Sampling_rate>48.0 KHz</Sampling_rate> 
  <Bit_depth>16 bits</Bit_depth> 
  <Compression_mode>Lossy</Compression_mode> 
  <Stream_size>624 MiB (8%)</Stream_size> 
  <Default>Yes</Default> 
  <Forced>No</Forced> 
  </track>
  </File>
  </Mediainfo>

<?xml version="1.0" encoding="UTF-8" ?> 
- <Mediainfo version="0.7.54">
- <File>
- <track type="General">
  <Unique_ID>246386272705662448639720718327631640195 (0xB95C4521EE0F30098F42A3C5C634F683)</Unique_ID> 
  <Complete_name>D:\Bluerays\00139-1.mkv</Complete_name> 
  <Format>Matroska</Format> 
  <Format_version>Version 2</Format_version> 
  <File_size>5.86 GiB</File_size> 
  <Duration>1h 0mn</Duration> 
  <Overall_bit_rate>14.0 Mbps</Overall_bit_rate> 
  <Writing_application>HandBrake 0.9.6</Writing_application> 
  <Writing_library>libmkv 0.6.5</Writing_library> 
  </track>
- <track type="Video">
  <ID>1</ID> 
  <Format>AVC</Format> 
  <Format_Info>Advanced Video Codec</Format_Info> 
  <Format_profile>Main@L4.0</Format_profile> 
  <Format_settings__CABAC>Yes</Format_settings__CABAC> 
  <Format_settings__ReFrames>4 frames</Format_settings__ReFrames> 
  <Codec_ID>V_MPEG4/ISO/AVC</Codec_ID> 
  <Duration>1h 0mn</Duration> 
  <Bit_rate>13.0 Mbps</Bit_rate> 
  <Width>1 920 pixels</Width> 
  <Height>800 pixels</Height> 
  <Display_aspect_ratio>2.40:1</Display_aspect_ratio> 
  <Frame_rate_mode>Variable</Frame_rate_mode> 
  <Frame_rate>23.976 fps</Frame_rate> 
  <Color_space>YUV</Color_space> 
  <Chroma_subsampling>4:2:0</Chroma_subsampling> 
  <Bit_depth>8 bits</Bit_depth> 
  <Scan_type>Progressive</Scan_type> 
  <Bits__Pixel_Frame_>0.354</Bits__Pixel_Frame_> 
  <Stream_size>5.48 GiB (93%)</Stream_size> 
  <Writing_library>x264 core 120</Writing_library> 
  <Encoding_settings>cabac=1 / ref=1 / deblock=1:0:0 / analyse=0x1:0x111 / me=hex / subme=2 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=1 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=10 / rc=crf / mbtree=1 / crf=19.0 / qcomp=0.60 / qpmin=3 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00</Encoding_settings> 
  <Language>English</Language> 
  <Default>Yes</Default> 
  <Forced>No</Forced> 
  <Color_primaries>BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177</Color_primaries> 
  <Transfer_characteristics>BT.709-5, BT.1361</Transfer_characteristics> 
  <Matrix_coefficients>BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177</Matrix_coefficients> 
  </track>
- <track type="Audio">
  <ID>2</ID> 
  <Format>AC-3</Format> 
  <Format_Info>Audio Coding 3</Format_Info> 
  <Mode_extension>CM (complete main)</Mode_extension> 
  <Codec_ID>A_AC3</Codec_ID> 
  <Duration>1h 0mn</Duration> 
  <Bit_rate_mode>Constant</Bit_rate_mode> 
  <Bit_rate>640 Kbps</Bit_rate> 
  <Channel_s_>6 channels</Channel_s_> 
  <Channel_positions>Front: L C R, Side: L R, LFE</Channel_positions> 
  <Sampling_rate>48.0 KHz</Sampling_rate> 
  <Bit_depth>16 bits</Bit_depth> 
  <Compression_mode>Lossy</Compression_mode> 
  <Stream_size>275 MiB (5%)</Stream_size> 
  <Default>Yes</Default> 
  <Forced>No</Forced> 
  </track>
  </File>
  </Mediainfo>

 

 

-Which firmware? 1.06.15 & 1.07.15
-What happened? WDTV SMP Freezes about 20-30 seconds after movie starts playing.
-What were you doing? Watching MKV file.
-Does this happen every time? Yes.
-What hardware and media were you using? WDTV SMP & MKV File
-Did this happen with previous firmware? Yes.
-Does power cycling the unit solve this? No.
-Does resetting to factory defaults solve this? No.
-Have you tried this on other devices? MKV Files plays fine on the WDTV Live & WDTV Live Plus.


 

 

Status: Investigating
Comments
by ‎04-06-2012 02:36 AM - edited ‎04-06-2012 02:41 AM

So, is downgrading to firmware 1.05....something is really a solution for this?

 

(I seem to only have this problem if I'm using my 2TB USB3 hard drive, no problem with my 320GB USB2 device.)

by on ‎04-11-2012 12:31 PM

Any news from WD side?

by ‎05-04-2012 06:15 AM - edited ‎05-04-2012 08:52 AM

Ok guys, I found the problem.  This issue is that Handbrake 0.9.6 uses libmkv 0.6.5 for it's writing library as were Handbrake 0.9.5 uses libmkv 0.6.4.1.

 

The problem is that the SMP can't handle, for some reason because the HUB can, the "libmkv 0.6.5" writing library.

 

So here's the simplest solution, with out having to re-encode your videos.  Just run them through MKVMerge, takes a few minutes depending on your file size,  which uses the "libebml v1.2.3 + libmatroska v1.3.0" library and the SMP doesn't have trouble playing.

by on ‎05-04-2012 10:41 AM
Tinwarble thanks for the info. Hopefully WD will include a fix in the upcoming firmware.
by on ‎05-07-2012 03:19 PM
Problem solved after running all my MKV files (The ones giving me problems) thru MKVMerge.
by on ‎05-10-2012 11:46 AM

I also confirm the workaround from Tinwarble works!

mkv's created with libmkv 0.6.4.1 work ok, it's the ones with 0.6.5 that cause the problem. Repacking them with mkvmerge solves it.

 

BTW: I also have the following behavior. If I stop the movie before it crashes, and then I try to open another file, this is what happens: The last frame of the previous movie is displayed, and the spinning loading arrow keeps spinning forever. Power on and off does not help, only a power-cycle will allow to play another file.

by on ‎05-10-2012 12:08 PM
Mouse256 I have the same problem. I tried stopping the movie as well with no luck lol.
by Staff on ‎06-12-2012 04:26 PM
Status changed to: Investigating
 
by on ‎06-22-2012 04:28 AM

I 'solve' the problem by transferring any films on to a USB attached HDD.  Unfortunately, given that this player has only two USB ports, and that using a hub to attach multiple USB HDDs is unreliable, and the fact that I have about 11TB of films, makes this difficult.

 

It only affects the odd film, but if I sit down to watch something and it freezes, it takes maybe 30 minutes+ to transfer a Blu-ray Disc rip from my MBL to an attached HDD.  Not only is this a pain, the missus won't wear it.

 

Note to WD.  Please include more USB ports on future players (and round the back, too), or make USB hubs work properly, all the time.

 

Cheers.

 

Steve W

by on ‎06-22-2012 05:10 AM

what kinda of usb hub are you using?

i have a 3tb elements & a 2.5tb elements hooked up to a powered hub and they work great with my SMP.

granted more cables is kinda clumsy...

Announcements
The Live Streaming Issue Reporting is a variation of our idea exchange being used for the purpose of reporting issues with your WD TV Live Streaming Media Player.

In order to effectively report an issue you are experiencing with your WD TV, please make sure you include:

- Which firmware?
- What happened?
- What were you doing?
- Does this happen every time?
- What hardware and media were you using?
- Did this happen with previous firmware?
- Does power cycling the unit solve this?
- Does resetting to factory defaults solve this?
- Have you tried this on other devices?

Our goal is to try to address the issues that are the most important to you. Use the kudos arrow to say "Me too!" if you see an issue that affects you.

Issue Statuses explained here.
Issue Statuses
Top Kudoed Authors
User Kudos Count
1
1
1
1
1
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2013 Western Digital Corporation, All rights reserved. | Trademarks | Privacy | Terms of Service | Terms of Use | Copyright | Contact WD