Firmware Version 1.05.18 for WD TV Live No longer able to use standard folder thumbnail

Status: Investigating
by on ‎12-21-2011 06:34 AM

After upgrading the folder thumbnail is replaced by the first video thumbnail in folder.

Status: Investigating
Comments
by on ‎12-21-2011 07:25 AM

Yep...  That's annoying...  

 

And since you didn't post all the required info, I'll do it on your behalf:

 

Which firmware:   Live SMP 1.05.18 and Hub 3.01.19

What happens:  The documentation says that "folder.jpg" will be used to represent the folder icon when browsing.   But that is no longer true.  folder.jpg is ignored, and the first available .metathumb for a movie file is used instead.

 

That makes the appearance of navigation unpredictable.

 

What were you doing:  Just browsing media normally.

Yes, it happens every time.

Hardware:  Either the SMP or the Hub;  it's media independent.

No, it did NOT happen with either prior firmware.

Power Cycling / Resets do NOT solve the issue.

 

by on ‎12-21-2011 08:08 AM

what a shame, this functionality was working beautifully in the last firmware, hope that means it will be easy to fix

 

 

by on ‎12-23-2011 04:58 PM

Until they come up with a proper firmware fix for this, I managed to implement a quick fix.

If your files are on a linux machine, just do a symlink to your folder.jpg files

 

ln -s folder.jp 000.metathumb

 

It seemed to take a rescan before my WDTV picked up this cheat, but it is working.

 

 

by on ‎12-27-2011 01:42 PM
Happening for me too. Annoying.
by on ‎12-31-2011 04:39 PM

I suspect this was a deliberate change. Previously if you didn't have a folder.jpg, there was no thumbnail at all. The new firmware now at least makes the folder have a thumbnail based on the thumbnail of the video. But obviously this has the unintended consequence of ignoring the folder.jpg's that we have deliberately put there, which in most cases are more appropriate than the video's thumbails (eg. take the case of a Season folder within a show. The folder.jpg may be the seasons dvd cover which is unique. The videos thumbnail is the same for every epside in every season. So at the point of navigating which season to look at, all seasons will have the same thumbail.)

 

I'd propose keeping the behavior of using the thumbnail from the video in the folder as the folders thumbnail, but ONLY IF there is no explicit thumbnail present. That way if you can't be bothered finding all the thumbnails and putting them in your folders, you don't get a blank thumbnail for your show. But if you want better thumbnails, you can override the default behavior just by dropping a folder.jpg into the relevant  folder.

by on ‎01-02-2012 08:21 AM

I bought the WDTV Live SMP a week ago, I've spent the past 3 days trying to work out why my folder icons were working for some initially then completely broke and now I finally realise it's the FW update!!! GRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRR!!!!!!!!!!!!!!!!!!!!!!!!!!!! Was soooo at the point of chucking it in bin/getting a refund (the whole freezing during .avi playback/freezing during general system use/idle was a kicker but that seemed to improve a little bit with the FW update)

I put all this work in because I wanted to make it really straightforward and easy to use visually for my folks but now all they've seen is my frustration and repeated plugging/unplugging of the unit. So now I've recompiled my media library about 10 times in an attempt to fix it and lost all the ratings I assigned to my movies and I find it's all broke anyway. Not happy.

by on ‎01-10-2012 04:15 PM

Anyone check if this issue is resolved in 1.06.04?

 

 

by on ‎01-11-2012 03:19 AM

yup, still a bug in latest firmware. How can something this simple get through quality testing?

by on ‎01-14-2012 12:33 PM

On the other WDTV's I think it displays the folder.jpg if available and if not then the first thumb it finds.

 

Obviously this is what everyone would want.

 

If it was a deliberate change, it was very short-sighted and now well thought out.

by Staff on ‎02-15-2012 10:38 AM
Status changed to: Investigating
 
Announcements
The Live Streaming Issue Reporting is a variation of our idea exchange being used for the purpose of reporting issues with your WD TV Live Streaming Media Player.

In order to effectively report an issue you are experiencing with your WD TV, please make sure you include:

- Which firmware?
- What happened?
- What were you doing?
- Does this happen every time?
- What hardware and media were you using?
- Did this happen with previous firmware?
- Does power cycling the unit solve this?
- Does resetting to factory defaults solve this?
- Have you tried this on other devices?

Our goal is to try to address the issues that are the most important to you. Use the kudos arrow to say "Me too!" if you see an issue that affects you.

Issue Statuses explained here.
Issue Statuses
Top Kudoed Authors
User Kudos Count
1
1
1
1
1
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2013 Western Digital Corporation, All rights reserved. | Trademarks | Privacy | Terms of Service | Terms of Use | Copyright | Contact WD