Reply
Occasional Advisor
computerguy
Posts: 11
Registered: ‎01-12-2010
0
Accepted Solution

Enable Network Shares on WD TV Live & Windows 7 & Vista 32-bit & 64-bit

[ Edited ]

I authored this tutorial in the attempt to aid anyone who was having issues connecting network shares over Windows 7.  I've been told this works for both the x64 and x86 versions, however, when I wrote it I intended it for x64 since that is what I use.

 

Hopefully this video can assist others.  Pardon the mic issues.  Batteries were dying I found out later.

 

http://www.youtube.com/watch?v=EQstgQ4eJCM

Occasional Visitor
core_rs
Posts: 1
Registered: ‎01-17-2010
0

Re: Enable Network Shares on WD TV Live & Windows 7 & Vista 32-bit & 64-bit

Thanks for this.  This actually works!

 

Now, the only issue I have and I know that a few others have mentioned this, is that when I turn on the WDTV Live, it takes anywhere from 10-45 mins for it to actually "wake up" and see the Network Shares.

 

Does anyone have a clue as to why this is happening ?

Occasional Advisor
serge
Posts: 11
Registered: ‎12-29-2009
0

Re: Enable Network Shares on WD TV Live & Windows 7 & Vista 32-bit & 64-bit

Tried this, it does not work in my case, still get invalid user name and password. ..But if , in the network advanced sharing screen, you disable media streaming ,as instructed in the video, you loose the media shares. Are you suggesting of using network shares instead? I'll give the part with folder sharing another careful try tonight but I don't think you take media shares out as that causes the media library, the folders you see in the library section of the windows explorer or windows media player, to disappear.
Advisor
Zetty
Posts: 22
Registered: ‎01-13-2010
0

Re: Enable Network Shares on WD TV Live & Windows 7 & Vista 32-bit & 64-bit

[ Edited ]

It's abnormal for the WDTV to take more than several minutes to access the network shares.  My box sees the shares (win XP, Vista and Win 7)  in less than 3-4 minutes.

 

I would check the cable and/or connections - if the connection is flaky it will cause lots of errors in transmission which results in repeatedly retries...

Occasional Advisor
serge
Posts: 11
Registered: ‎12-29-2009
0

Re: Enable Network Shares on WD TV Live & Windows 7 & Vista 32-bit & 64-bit

This was another thing I was going to change, the network cable that is, which is spliced using a network cable extender.

That could be a reason why the wdtv sees the wireless computer just fine in both, the media shares and network shares while the wired computer is only visible in media shares, less music library which is sometimes  is on sometimes off. Thanks for suggestion, I think this is the only thing I didn't try. 

Frequent Advisor
mystiky
Posts: 35
Registered: ‎01-19-2010
0

Re: Enable Network Shares on WD TV Live & Windows 7 & Vista 32-bit & 64-bit

Fantastic video!  Thank you!  The information there helps for the folks who are having problems with understand this whol business about "shared".

 

One quick question, I made my "WD Live" directory (instead of  Tutorial.  How come do I also see the USERS folder listed there?  I never turned it on to be shared and in my PC setup, I only have one user, without any password login.

 

It's not a big deal, but wondering why  my WD TV Live has access to that folder (and it's contents) besides the one created specifically via your suggested ways.

Occasional Advisor
computerguy
Posts: 11
Registered: ‎01-12-2010
0

Re: Enable Network Shares on WD TV Live & Windows 7 & Vista 32-bit & 64-bit

[ Edited ]

 


serge wrote:
Tried this, it does not work in my case, still get invalid user name and password. ..But if , in the network advanced sharing screen, you disable media streaming ,as instructed in the video, you loose the media shares. Are you suggesting of using network shares instead? I'll give the part with folder sharing another careful try tonight but I don't think you take media shares out as that causes the media library, the folders you see in the library section of the windows explorer or windows media player, to disappear.

 

Try this > on the WD TV Live go into Network Settings and change and Auto login to network share > On.  Reboot the device by pulling the power, waiting 15 seconds and plugging it back up.

 

Let me know if this works.

Occasional Advisor
computerguy
Posts: 11
Registered: ‎01-12-2010
0

Re: Enable Network Shares on WD TV Live & Windows 7 & Vista 32-bit & 64-bit


mystiky wrote:

Fantastic video!  Thank you!  The information there helps for the folks who are having problems with understand this whol business about "shared".

 

One quick question, I made my "WD Live" directory (instead of  Tutorial.  How come do I also see the USERS folder listed there?  I never turned it on to be shared and in my PC setup, I only have one user, without any password login.

 

It's not a big deal, but wondering why  my WD TV Live has access to that folder (and it's contents) besides the one created specifically via your suggested ways.


 

I'm happy it worked for you.  Love hearing about success stories.  To answer your question about why you see the USERS folder;  you have Password Protected Sharing turned off per my guide.  WIth that setting turned off you have something of a Windows Simple File Sharing going on. 

 

Try the following:
First, un-share the Users folder:

1. Open the C: disk.
2. Right-click the Users folder.
3. Click Properties (not Share).
3. Click Sharing.
4. Click Advanced Sharing.
5. Un-check "Share this folder".
6. Click OK.
7. Click Close.

Then, share the desired desktop folder:

8. Right-click the folder.
9. Click Properties (not Share).
10. Click Sharing.
11. Click Advanced Sharing.
12. Check "Share this folder".
13. Click OK.
14. Click Close.

 

 

Thanks to Steve Winograd, MS-MVP for this solution.  Googling save us time :smileyhappy:

http://www.vistax64.com/vista-networking-sharing/149437-when-i-share-desktop-folder-c-users-all-subf...

Frequent Advisor
mystiky
Posts: 35
Registered: ‎01-19-2010
0

Re: Enable Network Shares on WD TV Live & Windows 7 & Vista 32-bit & 64-bit

Hi Computer guy!

 

Well, I spoke too soon.  Really need help now:

 

http://community.wdc.com/t5/Networking/I-changed-my-router-and-now-I-can-t-even-see-my-Network-Share...

 

If you have any ideas, please reply here or there...

Frequent Advisor
mystiky
Posts: 35
Registered: ‎01-19-2010
0

Re: Enable Network Shares on WD TV Live & Windows 7 & Vista 32-bit & 64-bit

Out of desperation, I once again tried to reconnect the WRT300N router back on the system, and guess what? Everything is working like a charm again. I did not have to touch any settings on Windows 7 ... So this tells me that WD TV Live has incompatibility with the Linksys WRT610N v2 router and therefore, I am returning it back to the store. Funny enough, I watched 45 minutes of 1080i video yesterday without any "skipping" from my WRT300N, on a mixed signal using 20Mhz.
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2013 Western Digital Corporation, All rights reserved. | Trademarks | Privacy | Terms of Service | Terms of Use | Copyright | Contact WD