Reply
Advisor
sssstew
Posts: 17
Registered: ‎12-15-2010
0

"Compiling Media Library..." every time i turn it on

Why does my WD TV Live Hub always do the 'Compiling Media Library..." thing when i first turn it on, i just sat through it compile it all from my NAS, then to test i turned the box off (3 second power button) and when i turn it back on it shows Compiling Media Library at the top of the screen and i cant browse my Videos, Music or photos properly (have to browse folder structure after accepting the warning).

 

So why does it do this long process everytime i turn it on?  My wife and kids dont want to have to wait for this each time.......

 

Cheers

Stew

Valued Contributor
Frillen
Posts: 142
Registered: ‎12-12-2010
0

Re: "Compiling Media Library..." every time i turn it on

[ Edited ]

If you turn the hub completely off(3 second power off) it will always compile the media library, if you want to avoid this you should just press the power button shortly then it won't recompile once turned on.


Own: WD TV Live Hub (Fw 2.07.17) + Verbatim 1.5 tb usb hd + packard Bell 2 tb usb hd + Seagate 1 tb usb hd + Netgear ReadyNas Duo 2x2 tb on gigabit network
Occasional Advisor
Jimsampa
Posts: 6
Registered: ‎01-05-2011
0

Re: "Compiling Media Library..." every time i turn it on

Hi,

I just press the buton when I turn it off, but when I turn it on it compilling again and again every time

Advisor
sssstew
Posts: 17
Registered: ‎12-15-2010
0

Re: "Compiling Media Library..." every time i turn it on

So Jim - are you saying yours does it even when you only put it into standby? and not just the full power off?

 

Also if i only put it into standby so that it doesnt do this media compile does that mean it wont see the new files i add the NAS until i do a full turn off and back on?

Occasional Advisor
Jimsampa
Posts: 6
Registered: ‎01-05-2011
0

Re: "Compiling Media Library..." every time i turn it on

It never stopped compiling, it was compilling for 2 days and every time I turn it on it cuntinues the compilling

Respected Contributor
Vistawall
Posts: 255
Registered: ‎11-08-2010

Re: "Compiling Media Library..." every time i turn it on

Compiling Media Library... happens if WDTV LIVE HUB finds new files in order to do content aggregation, The speed at which this takes place depends on how fast your NAS share is and also how many files you have on the folder you have shared on the network, The new firmware requires that you have your network share in READ/WRITE mode so that it can create .wd-tv folder, and create thumb files for all the image files etc; etc; 

 

If the unit is always displaying  "Compiling Media Library..." it means it never finished the content aggregation process of the files and folder that it found.

 

In order to troubleshoot this, Please stop your network share and see if the WDTVLIVE HUB can finish the content aggregation of the internal HDD first, That also depends on how much files you have loaded on the internal drives but usually seen to complete in less than 30 mins, If you really want you can also clear the Media Library and let it re-compile for the internal HDD and let it finish the  content aggregation process 

 

Once you are sure that WDTV LIVE HUB has stopped displaying the "Compiling Media Library..." you can be sure that nothing else other than the speed and the sheer content of your NAS share is the cause of this constant  "Compiling Media Library..."  issue.

 

If you power-off the unit completely either by pulling the plug or pressing the power button on the front panel or remote for more than 3-4 secs it will completely shutdown the unit and it will have to re-compile the databases again.

 

I agree your frustration my friend, but that is how it is designed, It does not keep track of  the list of known files it aggregated the first time, it always find the files and re-compiles again and again when resumes from a full power-off. This unit is not designed to be turned off as it was designed to be a NAS server also.

 

When the Compiling Media Library... is displayed the unit can be used, It play movies, browse the online services just certain features like getting content metadata information is not available...

 

Hope this helps

 

With best wishes

 

 

WDTV SMPx1, WDTVLIVEHUB x1 , Win7 HTPC x2 WD Elements 2 TB x2, Seagate BlackArmor NAS 440 x1, My Book Live Duo 4TBx1, WD N900 Central 1TB.
*** I'm so sane, it's driving me crazy *** Website: http://rbhatta.blogspot.com/
Occasional Advisor
Jimsampa
Posts: 6
Registered: ‎01-05-2011
0

Re: "Compiling Media Library..." every time i turn it on

thanks

Valued Contributor
architectonic
Posts: 412
Registered: ‎01-10-2011
0

Re: "Compiling Media Library..." every time i turn it on

hi jim

 

i am currently experiencing very similar problems to your good self!

 

DID THE LAST PIECE OF ADVICE WORK FOR YOU??

 

I hope so.

 

i will post a full report upon my problems tomorrow, cos it is bedtime now and as i am so fustrated with my new WDtV live hub media player  i will not be able to make my issue clear!

 

BTW i really like the potential of this bit of kit BUT i have spent so much time p***ing about and reading forums etc, etc (lets say 2 days worth of f...kin around trying everything known to me) that i could have watched at least half my movie collection! Anyway not 2 worry- perhaps we can get to the bottom of this issue???

 

WD please advice soon upon further comm.

 

regards

 

paul

 

 

 

 

 

 

Occasional Advisor
Chuck_in_OZ
Posts: 5
Registered: ‎01-16-2011
0

Re: "Compiling Media Library..." every time i turn it on

Hi all,

 

Similar problem for me.  I'm new to this class of device and installed mine on the weekend.  It's connected to an XP PC (via EoP) that has thousands of photos and videos on it - stuff that I want to leave on the PC.

 

 After several frustrating hours I found the article on workgroup settings (if it's so important for the Hub - and wasn't required on previous devices - I'd expect it to be covered off before pg 130+ in the manual!) and now have my hub viewing some content on the shared drive.

 

After a device restart via the menu, the Hub started compiling media library last night.  Several hours later I went to bed with it still saying compiling.  This morning it was still going, so I switched it off with the RCU and power cycled it. Straight away it starts compiling again - I left for work an hour later and it was still going.

 

Is there something else I should do if it's still compiling when I get home, or does it normally take this long?

 

I want to love this device but am finding lots of reasons to regret my purchase.

 

Allan

 

 

Respected Contributor
Vistawall
Posts: 255
Registered: ‎11-08-2010
0

Re: "Compiling Media Library..." every time i turn it on

[ Edited ]

Chuck_in_OZ,

 

As I reported before, If the unit is always displaying  "Compiling Media Library..." it means it never finished the content aggregation process of the files and folder that it found... This process can take few mins on smaller library and can take a very long time if you have thousands of tiles and folders. 

 

Also, If the folders that you are sharing to the device changes constantly, "Compiling Media Library..." should automatically kick-in to aggregate those files and folders... May be that is what is happening to your case... The source directories that you are sharing may be changing on the fly and that is causing the non-stop "Compiling Media Library..."  displayed on your screen, If you power-cycle the WDTVLIVE hub, it will force the content aggregation from scratch... so you are back to square-one!

 

If you do not care about "Getting Meta-data" from the Internet, If you do not care about Movie Backdrops, If you do not care about "RESUME" playback on DVD files, you can disable Media Library, and you will never see that dreaded "Compiling Media Library..."  on your screen again!

 

Hope this helps

 

With best wishes

 

WDTV SMPx1, WDTVLIVEHUB x1 , Win7 HTPC x2 WD Elements 2 TB x2, Seagate BlackArmor NAS 440 x1, My Book Live Duo 4TBx1, WD N900 Central 1TB.
*** I'm so sane, it's driving me crazy *** Website: http://rbhatta.blogspot.com/
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2013 Western Digital Corporation, All rights reserved. | Trademarks | Privacy | Terms of Service | Terms of Use | Copyright | Contact WD