Posts: 2
Registered: ‎09-25-2013
Accepted Solution

WD Discovery Tool Password

After setting up my Live Hub, I downloaded and installed the Discovery Tool.  After opening the app and selecting Configure  a browser page is opened and I am prompted to enter a password.  I have tried the password assigned to the Hub without success.  I then searched this forum and found an answer suggesting ADMIN was the correct password.  I've tried this in Upper and Lower case but the page doesn't accept it  in either form.

Community VIP
Posts: 4,608
Registered: ‎01-05-2011

Re: WD Discovery Tool Password

[ Edited ]

The Password is :  admin


Then you need to      I accept   END USER LICENSE AGREEMENT


Then click:  Login


(if you have problems.. try a different browser eg. Firefox,Chrome etc .. if any firewall notifications, then click 'allow')

Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the 'Accept as Solution' button for the post that solved your issue. This may help someone else.

Posts: 2
Registered: ‎09-25-2013

Re: WD Discovery Tool Password

Thanks, I'm not sure what I was doing differently but I'm in now.  I thought I had tried it exactly as you instructed.


Thanks again,


Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2015 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD