Reply
Occasional Visitor
shudhavbinjamie
Posts: 1
Registered: ‎09-08-2012
0

WD My Passport could not be opened

My WD My Passport won't open on windows explorer. I've been using it for quite sometime on various computers but then suddenly it won't open anymore. It doesn't appear on My Computer but it appears in Device Manager. The LED light is blinking and the PC seems to detect it. I just can't open it. I've also tried using it on other PCs, it won't work.

Most solutions tells me to do something using Disk Management, but it says the device is Unknown and Not Initialized.

 

1.jpg

 

But when I try to initialize it, this appears...

 

2.jpg

 

HELP!!!!

 

 

Honored Contributor
Alucardx23
Posts: 4,266
Registered: ‎01-14-2012
0

Re: WD My Passport could not be opened

Try using only the USB cable that came with the Passport and use it connected straight to the PC, if that doesn't work you might need to replace it.

Click the Kudos star to say thank you for helpful posts and be sure to come back and 'Accept as Solution' under options for the post that solved your issue.
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2014 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD