Reply
Regular Visitor
lhui5484
Posts: 3
Registered: ‎02-24-2012
0

New WD Passport Essentail SE already broken?

Just got a new WD Passport Essential SE today. Went into the WDSmartware, clicked Update Software... > Get Update > Site loads > I download files > I try to update > I get: http://screensnapr.com/v/I7cTr7.png

I try to reformat it using the WD Quick Formatter, but that is broken too. What do I do?

Regular Visitor
lhui5484
Posts: 3
Registered: ‎02-24-2012
0

Re: New WD Passport Essentail SE already broken?

Anyone going to help?

Regular Visitor
lhui5484
Posts: 3
Registered: ‎02-24-2012
0

Re: New WD Passport Essentail SE already broken?

Is the WD community this bad?

Honored Contributor
Joe_S
Posts: 5,273
Registered: ‎08-04-2010
0

Re: New WD Passport Essentail SE already broken?

[ Edited ]

This is just a users forum not customer service. If nobody knows they don't post. When you tried the update did you turn off your AV and is your Adobe Flash up to date? Did you try different USB ports? Make sure it's connected direct and not using a hub.  If it's a desktop use a port on the back.Also don't use a cable longer than the one supplied.  What OS are you using and is it up to date? Do you have another PC to test it on?

Joe

Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the 'Accept as Solution' button for the post that solved your issue.
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2014 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD