Reply
Occasional Visitor
Geislingen
Posts: 1
Registered: ‎06-08-2012
Accepted Solution

My Passport not detected by Router USB port

My WD Passport (USB3.0) iTB can be used when directly connected to my Windows 7 laptop without any issue. When I recently bought my D-Link Router DIR-857 which has a USB 3.0 port I tried connecting my WD Passport drive to it for sharing files over the network, but cannot see it or access it on the network. When I connect a USB thumb drive to the router, I can see and share its contents on the network, but not the WD.

 

Is there a compatibility issue here or does the drive firmware needs to be updated?

 

I ask D-Link technical support and was told that the drive might have a compatibility issue.

 

Thanks

Honored Contributor
Joe_S
Posts: 5,200
Registered: ‎08-04-2010

Re: My Passport not detected by Router USB port

I don't think  you can use this drive as a network drive. Try posting in the network section you might find more help there.

Joe

Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the 'Accept as Solution' button for the post that solved your issue.
Collector
AngelFace
Posts: 1
Registered: ‎05-13-2012
0

Re: My Passport not detected by Router USB port

[ Edited ]

:smileyhappy:  This question was moved from its original post to this one, marked as the solution...if the answer is elsewhere, this is not the solution...on my Belkin Router, they work just fine for backing up (I have 2) but the port has to be initialized first..Once done, this works best if you are using your drive to store your media files..Programs, not so much.  The Portal is now my WD Bible!      https://westerndigital.secure.force.com/apex/WD_ProductsRegistered    It provided me with any and everything I needed, right down to my S/Nos., which had long disappeared on the units...Good Luck!

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2014 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD