Reply
Occasional Advisor
Chaozzak
Posts: 11
Registered: ‎01-15-2013
Accepted Solution

WD My Cloud - Slow transfer speed

Hello,

 

I am aware, that there are many topics about this issue and I read them all. However I did not find a solution for me.

 

I bought WD My Cloud 4TB and I got only 11MB/s transfer speed. This is my setup and flow:

 

1) Modem --> Router (WD My net n900) via Ethernet cable

2) WD My Cloud --> Router via Ethernet cable

3) Desktop PC --> Router via Ethernet cable

4) 1TB WD My Book external HDD --> Desktop PC via USB 3.0 cable

 

I should add, that I have a 1gigabit network card on my desktop, My net n900 is 1gigabit too and everything is wired. I am not using Wi-Fi for transfer.

 

I have to backup 1TB of data from that 1TB WD My book to my new My Cloud and transfer speed is stable but painfully slow - 11MB/s.

 

What I tried:

1) Transfer 1GB+ single file from My book external HDD (connected to desktop) to MyCloud = 11MB/s transfer speed

2) Transfer 1GB+ single file from Desktop to My Cloud = 11MB/s transfer speed

3) Connect My Book external HDD to My Cloud via USB 3.0 = ~8MB/s transfer speed

4) Connect My Cloud directly via Ethernet cable to desktop = don't remember, but it wasn't higher than 11MB/s

 

In addition, I tried drag and drop method via Windows explorer, installed my cloud app for desktop and even used teracopy. But transfer speed was same.

 

It have to be a problem in my network, because I can't go further than 11MB/s (in one point I had 14MB/s, but only for few secs), but I just can't figure out why :-(

 

So, transferring 1TB data with 11MB/s is nightmare. If you guys got any tips, I would really appreciate it. Thank you very much

 

 

Have a great day,

Chaozzak

 

 

PS: When I plug 1TB My book external HDD to Router via USB and tried to copy a large file from desktop, I have around 20-40 MB/s. But that 20MB/s is stable.

Honored Contributor
richUK
Posts: 6,734
Registered: ‎12-09-2009
0

Re: WD My Cloud - Slow transfer speed

[ Edited ]

Are you connected to the router via wifi as well as Ethernet?

Have you tried different Ethernet cables?

Are you sure you are connected at the top speed on your desktop?

Is there anything else connected on your router / PC card?

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
WDTV Live Streaming; WDTV Live; WD Live Hub; My Book Live. Running Windows XP on a PC / Laptop.
Occasional Advisor
Chaozzak
Posts: 11
Registered: ‎01-15-2013
0

Re: WD My Cloud - Slow transfer speed

Hi richUK,

 

1) My Cloud and my desktop are connected only via Ethernet cable to my router. However my other devices as Tablet/phone are connected wirelessly, but that's not the case here I think.

 

2) My cloud and Desktop are connected to the router via Cat6 cable. I tried different cables but no luck

 

3) I am not sure, because I really don't know how to test it :-) I got 80Mbit/s internet and my download is around 10-12MB/s, so that's accurate I think.

 

4) Normally yes. There is one more Ethernet cable going to slow 10/100 switch but I disconnected this cable to test the transfer speed. So right now, on router are only My cloud, Desktop and Ethernet cable going to modem

 

 

Thanks

Honored Contributor
richUK
Posts: 6,734
Registered: ‎12-09-2009
0

Re: WD My Cloud - Slow transfer speed

Is there an network icon in the system tray on your desktop?

If you hover over it does it show you the connection speed.

It may be that you are connected at 100 instead of 1000.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
WDTV Live Streaming; WDTV Live; WD Live Hub; My Book Live. Running Windows XP on a PC / Laptop.
Occasional Advisor
Chaozzak
Posts: 11
Registered: ‎01-15-2013
0

Re: WD My Cloud - Slow transfer speed

[ Edited ]

Local_Network.jpg

 

My OS is in Czech. But "Rychlost" means Speed and I got there 1,0 Gb/s. That should be ok, right?

 

And in the upper part connection (Připojení) says:

Connection via IPv4 - Internet

Connection via IPv6 - Connection to the internet is not available. (dunno if that matters, sorry :-))

Honored Contributor
TonyPh12345
Posts: 22,868
Registered: ‎01-11-2010

Re: WD My Cloud - Slow transfer speed

What color are the LEDs on the network connector of the My Cloud?

===Live SMP / Live Hub x2 / Live+ / Live x2 / 24 TBytes of QNAP + WD NAS ===
Occasional Advisor
Chaozzak
Posts: 11
Registered: ‎01-15-2013
0

Re: WD My Cloud - Slow transfer speed

My Cloud got non-blinking blue led on. Even if there is a transfer to My cloud, the led is not blinking - it just lights blue.

Honored Contributor
TonyPh12345
Posts: 22,868
Registered: ‎01-11-2010
0

Re: WD My Cloud - Slow transfer speed


Chaozzak wrote:

My Cloud got non-blinking blue led on. 


I'm asking about the REAR port (the port where the network cable is connected.)   What color are those LEDs.

 

 

===Live SMP / Live Hub x2 / Live+ / Live x2 / 24 TBytes of QNAP + WD NAS ===
Occasional Advisor
Chaozzak
Posts: 11
Registered: ‎01-15-2013
0

Re: WD My Cloud - Slow transfer speed

[ Edited ]

TonyPh12345 wrote:

I'm asking about the REAR port (the port where the network cable is connected.)   What color are those LEDs.


 

Network cable in MyCloud got blinking green and stable yellow one.

The opposite side of this network cable in router got blinking yellow and stable green.

Honored Contributor
TonyPh12345
Posts: 22,868
Registered: ‎01-11-2010

Re: WD My Cloud - Slow transfer speed


Chaozzak wrote:

Blinking green and stable yellow one.


That means your Cloud is only connected at 100 meg, not gig.   The light should be green.

 

===Live SMP / Live Hub x2 / Live+ / Live x2 / 24 TBytes of QNAP + WD NAS ===
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2014 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD