Reply
Occasional Visitor
suenwaichit
Posts: 4
Registered: ‎12-08-2013
0
Accepted Solution

File transfer over Internet stuck at 0% but complete eventually

Hi, I have setup Cloud Access for My Cloud 4TB and I can setup connection over the Internet via WD2GO. However my problem is when I open a share in Windows Explorer and do some file transfers, it stucks at 0% for long time before I see actual transmission. In the following example, I copy a 2.45GB ISO from My Cloud to a remote desktop. The total time it took to transmit is 4 minutes 40 seconds, but the prgress bar shows 0% for the first 3 minutes 45 seconds. Is this normal? I am very curious if My Cloud is doing any work with that given time.

 

 

mycloud0.png

mycloud1.png

Staff
HDKnows
Posts: 1,673
Registered: ‎04-13-2013
0

Re: File transfer over Internet stuck at 0% but complete eventually

[ Edited ]

Hello,

 

I think this is Windows trying to calculate files moving from a remote location.

Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the 'Accept as Solution' button for the post that solved your issue. This may help someone else.
Occasional Visitor
suenwaichit
Posts: 4
Registered: ‎12-08-2013
0

Re: File transfer over Internet stuck at 0% but complete eventually

I am confused if Windows really took 3 minutes 45 seconds to calculate file size and 55 seconds to actually transfer the file. The overhead is way too much. :smileyfrustrated:

Frequent Advisor
WilliamH
Posts: 55
Registered: ‎10-26-2011

Re: File transfer over Internet stuck at 0% but complete eventually


suenwaichit wrote:

I am confused if Windows really took 3 minutes 45 seconds to calculate file size and 55 seconds to actually transfer the file. The overhead is way too much. :smileyfrustrated:


Welcome to the wonderful world of the Windows implementation of WebDav. I'm only running WinXP (32bit) and I currently only have a MyBookLive (hoping to get a MyCloud when the dust settles on the USB issue), so my experience may not be directly applicable to your situation. However what I suspect was happening was that the 3 minutes and 45 seconds was the actual transfer from the remote location to a temporary location on the Windows boot partition. Try another transfer and observe network activity; you will likely see network activity (the actual file transfer) from the remote locationto your PC. Once the file is all in your PC, Windows will assess its parameters and then will transfer it from that temporary location on your boot partition to where ever you specified that the file should be saved to. That last local transfer would be your 55 second transfer. I have no idea why Microsoft implemented WebDav in this peculiar way. It all seems a rather odd and at times frustrating implementation.

 

 

Occasional Visitor
suenwaichit
Posts: 4
Registered: ‎12-08-2013
0

Re: File transfer over Internet stuck at 0% but complete eventually

Thank you for sharing your experience. Your points make sense to me. I followed your suggestion to observe the network activity and you are right. That progress bar is so confusing for not showing the remote transfer. Another thing I observed is that even I paused or cancelled the operation, I didn't see the network activity to drop or stop. I also tried the WD My Cloud desktop client which can display the actual progress but only transmit at half of the speed as Windows Explorer :catsad:. I'm using Windows 8.1 and it's sad Microsoft still haven't get this simple thing right.

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2014 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD