Reply
Occasional Visitor
Keeprighton
Posts: 4
Registered: ‎03-07-2014
0

Device Offline - This device is inaccessible

Set up my 2TB WD My Cloud NAS easily enough, and loaded files to drive.

 

Everything working fine on my home network, accessing files no problem on Iphone/Ipad via wifi.

 

BUT .... cannot connect using other wifi networks or via mobile 4G/3G. I get message "Device Offline' 'This device is inaccessible; only local files are available'

 

Can anyone help? This rather defeats the object of a cloud!

 

Thanks

Respected Contributor
cat0w
Posts: 616
Registered: ‎01-25-2014
0

Re: Device Offline - This device is inaccessible

[ Edited ]

You are not providing a lot of information to work with.

 

First did you set the My Cloud up using an Apple computer?

 

Have you checked the dashboard to make sure cloud access is on and set up?
WDMCRemoteAccess.JPG

 

 

Taking a look in the User Manual and reading it should help you out a lot.
http://www.wdc.com/wdproducts/library/UM/ENG/4779-705103.pdf

 

 

Occasional Visitor
Keeprighton
Posts: 4
Registered: ‎03-07-2014
0

Re: Device Offline - This device is inaccessible

Yes, latest  iMac.

 

Cloud Access on, Remote Access on, and it works absolutely fine via wifi on my mobile apps (iphone/ipad). Just nothing over 4G/3G.

 

 

Trusted Contributor
tnynyn
Posts: 463
Registered: ‎10-03-2013
0

Re: Device Offline - This device is inaccessible

I get that sometimes, its just spotty internet on the client side.  Once i get better signal, the issue goes away.

Occasional Visitor
Keeprighton
Posts: 4
Registered: ‎03-07-2014
0

Re: Device Offline - This device is inaccessible

Sure, but I'm getting same 'Device Offline' right now on a different wifi network. It only seems to recognise my home network.

Frequent Visitor
metroliner
Posts: 1
Registered: ‎04-22-2014
0

Re: Device Offline - This device is inaccessible

I am having the same issue after the latest firmware update.

Have not been happy with the connectivity and downtime.

 

I have the router set properly (static IP) and ports forwarded correctly. However, instructions for forwarding ports were not that clear. On a Linksys EA4500 router, use single port forwarding. Set external ports to any available port, but the internal ports had to be set to 80 and 443. This took me awhile to figure out that I had to use those specific internal ports. Dashboard says ports are forwarded and connection status is connected.

 

Currently I can connect on my home network via wifi on my ipad. But when on the cellular network, I get the error message "the device is inaccessible; only local files are available".

 

(Another gripe I had was when the WD servers went down a few weeks ago, I did not realize it until after factory resetting the device (and losing all my files).

 

 

Occasional Advisor
Defiant81
Posts: 7
Registered: ‎04-30-2014
0

Re: Device Offline - This device is inaccessible

Why did you ask if you set the my cloud up using a apple computer.. is there something different with this compared to a pc?

Advisor
Daran
Posts: 12
Registered: ‎04-29-2014
0

Re: Device Offline - This device is inaccessible

I have exactly the same problem..

 

I have My Cloud set up on the home business broadband line.

If I use my win 7, or win 8 laptops or my iphone via the same business broadband wifi it works fine.

 

However, if I switch any of them to my other personal home broadband line I lose the connectivity.

 

The frustrating thing is that all of this was working up until around a week ago... I have changed nothing on my end but it now no longer works and I get "Can't connect to this device"!

 

I have tried deleting the My Cloud icon from the laptop app, and deleting the whole mobile app and readding but to no avail.  I have also tried most of the other things suggested on this site including diabling/enabling upnp.

 

The My Cloud device itself is set up correctly as it was previously working and the desktop app says my account's cloud connection has a port forwarding connection established.

 

This is extremely frustrating...!!!

Honored Contributor
Etupes
Posts: 858
Registered: ‎01-03-2014
0

Re: Device Offline - This device is inaccessible

What external ports are you forwarding to the NAS? If you have forwarded external ports 80 and 443 to the NAS internal ports 80 and 443, be aware that some ISP are blocking access to port 80. To remedy this, you will have to choose other external ports to forward to your NAS. For example 8080 to 80, and 8443 to 443

----------------------------------------------------------------------------------------
With Kudos, contributors keep high spirits!
If you found my post helpful, click on the star in the left navigation panel...
Advisor
Daran
Posts: 12
Registered: ‎04-29-2014
0

Re: Device Offline - This device is inaccessible

not explicitly forwarding any ports - I am using a  BT Home Hub 5 with upnp enabled.

 

However, it looks like I have fixed it.

 

I looked in the BT Home Hub Event log - it was forwarding the following:

07:17:12, 30 Apr.(33988.450000) Port forwarding rule added via UPnP/TR064. Protocol: TCP, external ports: any->22857, internal ports: 22857, internal client: 192.168.1.71
07:17:08, 30 Apr.(33984.070000) Port forwarding rule added via UPnP/TR064. Protocol: UDP, external ports: any->22857, internal ports: 22857, internal client: 192.168.1.71

 

I disabled "Remote Access" in the My Cloud Settings/Cloud Access settings and then re-enabled and the Event log showed:

21:46:29, 30 Apr.(86143.210000) Port forwarding rule added via UPnP/TR064. Protocol: TCP, external ports: any->9444, internal ports: 443, internal client: 192.168.1.77
21:46:24, 30 Apr.(86138.690000) Port forwarding rule added via UPnP/TR064. Protocol: TCP, external ports: any->9091, internal ports: 80, internal client: 192.168.1.77

 

So it looks like before I did this, the ports being forwarded by UPNP were a bit screwed but turning remote access off/on has reset it to correctly forward to the right 443/80 internal ports!!

 

Hurrah!

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2014 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD