Reply
Established Member
simor
Posts: 4
Registered: ‎02-05-2014
0

Cloud access not working

[ Edited ]

Hi everyone

I am experiencing some problems with Cloud access to my new WD MyCloud, and I can tell I'm not the only one. I have browsed through several posts here, and I cannot seem to find a solution.

I get this message:

”Connected (Relay connection established)
Port forwarding failed to connect on port 8080 and port 8441”


When trying to connect through Firefox, it says unable to connect to server.

When trying to connect through FileZilla, it says “”Connection established” and then after a few seconds the connection is lost due to timeout.


I have followed TonyPh12345’s HOW TO (http://community.wd.com/t5/WD-My-Cloud/HOW-TO-Troubleshooting-Remote-Connectivity-Issues/m-p/617261#... in order to set everything up correctly.

In the WD’s browser UI I have set a static IP and enabled FTP.

I am not new to port forwarding (but Im no expert either), and I have forwarded the two ports that I have set, which are 8021 and 8441. I have tried several other ports as well.

I have tried putting the static IP under DMZ - no luck.

I cannot find an option to allow UPNP - is that a must? In this case the problem lies within my router..

I have a Cisco EPC5925 modem with build in router. The settings are limited, since it's provided by my internet provider. The MyCloud is connected via cable.

The MyCloud does have internet access and can be accessed through the app on my phone, for instance.


Any suggestions? Anything I may have overlooked?

 

 

*edited since my original post confused FTP with remote access..*

Honored Contributor
TonyPh12345
Posts: 22,795
Registered: ‎01-11-2010
0

Re: FTP access not working

[ Edited ]

None of that has anything to do with FTP.    FTP and Cloud Access aren't the same thing, and aren't related at all.

 

The ports aren't related, either.. FTP uses ports 20 and 21, regardless of what ports you have configured for Cloud access.

 

===Live SMP / Live Hub x2 / Live+ / Live x2 / 24 TBytes of QNAP + WD NAS ===
Regular Advisor
SlimyPizza
Posts: 101
Registered: ‎01-30-2013
0

Re: FTP access not working

I found the following which may be of help.  See the final post.

 

http://community.wd.com/t5/WD-My-Cloud/FTP-access/td-p/614085

Respected Contributor
cat0w
Posts: 590
Registered: ‎01-25-2014
0

Re: FTP access not working

The following link will take you to ftp information in the Knowledge Base.

 

http://wdc.custhelp.com/app/answers/detail/a_id/2680/session/
L3RpbWUvMTM5MTYzNjU2My9zaWQvMlJPbE5iTWw...

 

I hope this helps.

 

 

 

 

 

 

Established Member
simor
Posts: 4
Registered: ‎02-05-2014
0

Re: FTP access not working

Thanks for your inputs so far, but I had already been through the two guides you have posted.

Honored Contributor
TonyPh12345
Posts: 22,795
Registered: ‎01-11-2010
0

Re: FTP access not working


simor wrote:

Thanks for your inputs so far, but I had already been through the two guides you have posted.


....and?   So what did you change as a result?

===Live SMP / Live Hub x2 / Live+ / Live x2 / 24 TBytes of QNAP + WD NAS ===
Trusted Contributor
tnynyn
Posts: 461
Registered: ‎10-03-2013
0

Re: FTP access not working

If you can't find UPNP, then do the port forwarding. Post a screenshot if you can of your port forwarding settings in your router.

Regular Advisor
SlimyPizza
Posts: 101
Registered: ‎01-30-2013

Re: FTP access not working

Established Member
simor
Posts: 4
Registered: ‎02-05-2014
0

Re: FTP access not working

As a result to the first replies, I changed the title of this post..

 

I had been through the guides that you have linked me to before I made this post in the first place, so unfortunately they did not help.

 

I have tried forwarding different ports, but the connection is still listed as Relayed. I have forwarded other ports as well for different apps, and they work fine, so the forwarding is done correctly. 

 

I should be able to access the server from Filezilla, though, but I haven't had any luck so far.

Honored Contributor
TonyPh12345
Posts: 22,795
Registered: ‎01-11-2010
0

Re: FTP access not working

Dude, you're not paying attention. The "Relay" status to which you refer is ONLY relevant to cloud access. It has NOTHING to do with FTP, nor does the port configuration within the Cloud's UI. If you want to forward ports for FTP, it's all up to you. You have to forward to ports 20 and 21.
===Live SMP / Live Hub x2 / Live+ / Live x2 / 24 TBytes of QNAP + WD NAS ===
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2014 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD