Reply
Collector
Dragonfly
Posts: 2
Registered: ‎02-18-2010
0

MyBook World Died, DMG Clone Won't Mount

I had a 1 TB Western Digital MyBook World (blue rings) that failed. I was able to take apart the drive and get it spinning again by placing it in the freezer. Unfortunately, it would not mount using a USB adapter or the NAS enclosure it came with.

I was finally able to get Data Rescue 3 to see it using the USB adapter. At that point, I used the software to make a clone to a DMG on a new drive.

Apparently, the drive was originally a Linux RAID (without mirrors), and that's what the DMG is. So, there are four volumes under the one DMG. I think I need only the fourth one though.

Unfortunately, I cannot get the DMG to mount. I've tried DiskImageMouter, Disk Utilities, Burn, and Springy. Every single one of them tells me that there's no mountable system. Disk Utilities can see the DMG and its four volumes.

I have also tried to mount it in Linux (Ubuntu) via Parallels Desktop. I do have access to Windows XP, Vista, and 7 machines, but I have not tried them.

Is there anything I can do to salvage my files, preferably with the same folder structure.

So far, I can still access the drive itself through the USB adapter, if that helps any.

I saw in another thread that having the HDID for the DMG can help, so it's below.

Thank you for any ideas.

MacBook Pro (Core2 Duo)   Mac OS X (10.5.8)  

Collector
Dragonfly
Posts: 2
Registered: ‎02-18-2010
0

Re: MyBook World Died, DMG Clone Won't Mount

Apparently, I cannot post my HDID due to the posting settings. I know it's too long, so I was going to break it up, but then I'm told that it contains invalid HTML code.

 

If someone can tell me how to do that, I'd really appreciate it.

 

Thank you.

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2013 Western Digital Corporation, All rights reserved. | Trademarks | Privacy | Terms of Service | Terms of Use | Copyright | Contact WD