Reply
Occasional Contributor
jboejackson
Posts: 7
Registered: ‎09-29-2012
0

My Net 900 - WORST ROUTER EVER

I recently purchased the My Net 900. I was intrigued by the 2TB HD and the parental controls. This router was a major upgrade from my Linksys WRT610N. I have only had this new router for two weeks and have had dropped wireless connections, endless router resets, the 2TB HD is rarely recognized in the SmartWare, and I can never get in touch with customer support. Three days ago I requested a RMA and still have not heard back from WD. I am going to re-install my old Cisco and look for a better product.

Honored Contributor
Alucardx23
Posts: 4,266
Registered: ‎01-14-2012
0

Re: My Net 900 - WORST ROUTER EVER

Hello, I have a MyNet 900C 1TB, I used to have the same problems, but after updating the firmware it's a lot better. try doing the same.

Click the Kudos star to say thank you for helpful posts and be sure to come back and 'Accept as Solution' under options for the post that solved your issue.
Senior Member
AlexBerd
Posts: 3
Registered: ‎09-19-2012
0

Re: My Net 900 - WORST ROUTER EVER

Hi,

 

Before latest firmware update I had regular daily router Internet disconnections (almost in the same time of every day) and persistent problems with wd2go mobile access through IPad/IPhone. After last firmware update these issues seem to be disappeared.

 

Though in the update discription, there is no any mention about fixes for these specific issues... Anyway, it works. So, I'd rather join Alucardx23 idea to try the latest firmware update or to wait a bit for further firmware updates.

 

As far as can understand, hardware itself has a very good potential.

 

 

Best regards,

 

Alexei

Occasional Contributor
jboejackson
Posts: 7
Registered: ‎09-29-2012
0

Re: My Net 900 - WORST ROUTER EVER

Thanks for the response. As you can see I am very frustrated at this product and lack of WD response to fix it. I have updated the router firmware and Smartware and I am having the same issues. I may just have bad hardware. I submitted a request to replace the product (RMA) last week but still have not recieved any information.

Advisor
RocketScience
Posts: 24
Registered: ‎12-16-2012
0

Re: My Net 900 - WORST ROUTER EVER

I also recently purchased a N900 based on the hardware features and the associated software apps.  This replaced a Belkin N750 that didn't have all the features that their older routrer had that I really needed. I have also experienced a vast array of issues with the N900 to put me in the same viewpoint as yourself.  However, after much diligence, I am in contact with WD's Level 2 support, just received a replacement router, and will work on many of the issues that I and many others have experienced. I have held  positions in advanced automation technical support and am willing to work in depth with WD to help resolve these problems as I do think the hardware has great potential over much of the competition. I can't say how long it will take, but as long as we can determine the issue, provide temporary work arounds and get a committment from WD to resolve any found issues in a timely manner, then we will all end up with a better product.  In the mean time, it just takes patience.

Frequent Advisor
varxx
Posts: 30
Registered: ‎10-09-2012
0

Re: My Net 900 - WORST ROUTER EVER


RocketScience wrote:

I also recently purchased a N900 based on the hardware features and the associated software apps.  This replaced a Belkin N750 that didn't have all the features that their older routrer had that I really needed. I have also experienced a vast array of issues with the N900 to put me in the same viewpoint as yourself.  However, after much diligence, I am in contact with WD's Level 2 support, just received a replacement router, and will work on many of the issues that I and many others have experienced. I have held  positions in advanced automation technical support and am willing to work in depth with WD to help resolve these problems as I do think the hardware has great potential over much of the competition. I can't say how long it will take, but as long as we can determine the issue, provide temporary work arounds and get a committment from WD to resolve any found issues in a timely manner, then we will all end up with a better product.  In the mean time, it just takes patience.


@RocketScience: You've got a positive outlook, that's for sure. I'd be a little more positive except that I can't help thinking that WD rushed this router to the market without adequate testing, and now we're all paying $175 for the privilege of testing a dodgy product, plus return shipping charges when we have to send a unit back to the factory.

Occasional Advisor
chucklesmcgee
Posts: 7
Registered: ‎01-12-2013
0

Re: My Net 900 - WORST ROUTER EVER

Yeah I agree. My unit started turning on and off on the network, dropping wireless connections, and I presume overheating entirely (firmware couldn't be accessed by ethernet). Only got about 6MB/s write over a gigabit connection.


The new unit I got seems to be doing alright-upgraded from 1.03.11 out of the box which was stable and kept the fan working and just updated to 1.06.whatever. The drive might work fine now, but WD made a stupid marketing decision rushing a product like this to market.

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2013 Western Digital Corporation, All rights reserved. | Trademarks | Privacy | Terms of Service | Terms of Use | Copyright | Contact WD