Occasional Advisor
Posts: 10
Registered: ‎11-25-2013
Accepted Solution

Can't map to Private Share in Windows Explorer

I can map to the \Public\ share no problem, by typing \\WDMyCloud\Public\ in Windows Explorer.  I created a new Public share called "Stuff", and can map to it by typing \\WDMyCloud\Stuff.


I then created a new share called "Private", then turned Public to Off.  I then selecting my user account (I'm the admin) and granted Full Access.  When I try to navigate to that share (\\WDMyCloud\Private), I receive a security prompt to enter my username and password.  I have tried every combination, but nothing seems to work.


What username / password am I supposed to put into this prompt?  I've tried my WD Mycloud email and password, I've tried my email and "MyCloud Access Code", etc.

Honored Contributor
Posts: 24,296
Registered: ‎01-11-2010

Re: Can't map to Private Share in Windows Explorer

You use the username you defined in the Cloud.  Not an e-mail address; it's just a username.


Then you use the password assigned to that user.


If you have already connected to a PUBLIC share, you will not be able to connect to a PRIVATE share as that's a limitation of Windows.


You'll need to disconnect all connections to the Cloud, then try connecting to the Private share first.    Then you can access public shares after that.


===Live SMP / Live Hub x2 / Live+ / Live x2 / 24 TBytes of QNAP + WD NAS ===
Occasional Advisor
Posts: 10
Registered: ‎11-25-2013

Re: Can't map to Private Share in Windows Explorer

Thanks TonyPH!  That was my issue (well, that and it required a reboot).


To get this to work, I had to do all of the following:

- Disconnect any driver already mapped to the WDMyCloud device

- Close wd2go site (and all other open browser windows)

- I cleared out "Recent Places" in Windows 7, and deleted all my browser history

- I rebooted my PC.  After doing all of the above, I still could not map the drive until I rebooted.


Once I rebooted, I was able to add the network drive and enter my credentials (username, not email, and password set through the drive's user interface).

Occasional Visitor
Posts: 1
Registered: ‎02-06-2014

Re: Can't map to Private Share in Windows Explorer

Finally!!! I've been looking for an answer to this problem that actually worked. This was it.

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2015 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD