Reply
Occasional Contributor
DarkMonohue
Posts: 4
Registered: ‎08-03-2012
0

WD My Book Live Not Found

I'll try not to go too heavily into the details; let me know if more would be helpful.  I have a WD My Book Live 2TB hooked up to my network by Ethernet cable.  I was using the drive fine.  Then it became “not found”.  It used to appear in the “Computers” section of the Windows Explorer: Network window, but now doesn’t.  It appears in the “Storage” section of that window, and when I double-click on it, I get to the device web page, where (at the bottom) it reports that the status of the drive is “good.”  But if I right-click on it, and choose “open” or “mount public share”, nothing happens.  The light stays green the whole time.  Help!

Occasional Contributor
DarkMonohue
Posts: 4
Registered: ‎08-03-2012
0

Re: WD My Book Live Not Found

Sorry, just realized this should have gone into the  "Network Products" section.  I'll take it there.

Honored Contributor
Alucardx23
Posts: 4,266
Registered: ‎01-14-2012
0

Re: WD My Book Live Not Found

Try using the WDlink to map the My Book.

 

http://wdc.custhelp.com/app/answers/detail/a_id/8573/session/L3RpbWUvMTM0NDExMjQ4MS9zaWQvZ25scDhUMmw...

Click the Kudos star to say thank you for helpful posts and be sure to come back and 'Accept as Solution' under options for the post that solved your issue.
Occasional Contributor
DarkMonohue
Posts: 4
Registered: ‎08-03-2012
0

Re: WD My Book Live Not Found

That doesn't seem to work.  When I go into WD Link, it finds my drive just fine, but doesn't seem to be able to locate shares on it.  When I click on the drive in the top ("Devices Found") pane, the buttons for that pane ("Create... Refresh... Configure") go live, but nothing appears in the bottom pane (Drive Map), and the buttons there remain grayed-out. 

Occasional Visitor
teflotone
Posts: 1
Registered: ‎09-09-2012
0

Re: WD My Book Live Not Found

I have had exactly the same problem..  Using Windows 7 64 bit home edition.

 

I tried calling customer support and after trying for a while with the Rep, he said he would have to call me back in a few minutes.  that was a week ago.

 

I can find the WD Live everywhere else - on Xbox on ipod etc etc  Just cannot map the network drive so I can easily access the public folder.  WD Link doesn't work and you can't do it manually as it doesn't show on the network.

 

Any ideas or is this a Windows/WD issue that both companies are ignoring?

Advisor
SIS425
Posts: 11
Registered: ‎09-10-2012
0

Re: WD My Book Live Not Found


DarkMonohue wrote:

I'll try not to go too heavily into the details; let me know if more would be helpful.  I have a WD My Book Live 2TB hooked up to my network by Ethernet cable.  I was using the drive fine.  Then it became “not found”.  It used to appear in the “Computers” section of the Windows Explorer: Network window, but now doesn’t.  It appears in the “Storage” section of that window, and when I double-click on it, I get to the device web page, where (at the bottom) it reports that the status of the drive is “good.”  But if I right-click on it, and choose “open” or “mount public share”, nothing happens.  The light stays green the whole time.  Help!



I have the same issue today. No help but saying ditto!

 

Windows 7

Can see MyBookLive2TB via Network & QuickView and accessible to  WD Smartware,

cannot map a drive or access share or view the drive through "Computer" interface.

 

MyBookLive2TB is connected to router and has DHCP IP setting.

 

At this time I do not have another Operating System to test if it can be done through another OS.

 

Help! I use this as a storage device for large project data collecting. Time is money and I am losing both! 

Advisor
SIS425
Posts: 11
Registered: ‎09-10-2012
0

Re: WD My Book Live Not Found

Update -

Resolved my issue don't know if this will help others-

 

I use Kaspersky Pure, after reading many posts about checking your firewall I finally did. I was sure since it worked before the firmware upgrade it would not be the firewall.

 

In my firewall network settings, originally my network was set up in Kaspersky as "public" not "trusted", changed it to "trusted" , rebooted and the magic happened I can now use my MBL with network mapping and see all the shares and folders.

 

One of the reasons I did not check this before is my music located on the MBL drive was available to itunes on my PC, therefore I did not believe it was a firewall issue.

 

Good Luck!

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2014 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD