Reply
Visitor
truonginfo01
Posts: 1
Registered: ‎07-19-2012
0

Set Password for My Book Live

Hi all,

 

I have a My Book Live, i use it for store security database. So now i want to set a password for Public folder in My Book Live. I try to do the same the direction below but it didn't work.

How can i set password for that folder or remove that folder or disable it

(Re: Removing public folder[ Edited ]

This one is easy.

 

Enable SSH.

Download a Secure Telnet  client like PUTTY if you're using Windows.

Log into to MyBook Live's Linux operating system.

Use the nano text editor to alter a file named /etc/trustees.conf

Find:

[/dev/md3]/shares/Public:*:RWBEX:*:CU

Change it to:

[/dev/md3]/shares/Public:admin:RWBEX:*:CU

Also make the same change to /tmp/trustees.mod

 

Finally use this command:

settrustees -f /tmp/trustees.mod

If you change the Public share using the Dashboard UI you will need to re-apply the changes above but why you would wish to change the Public Share in the Dashboard is a bit beyond me as all you can do is change its comment.

 

With this change ONLY the owner user (or admin) has access to the Public share.  Even works for FTP.  The FTP client will be able to see the Public share but won't be able to access it.

 

I'm not sure how this will affect the iTunes server and the DLNA server.)

 

Thank you!

Honored Contributor
Wizer
Posts: 3,894
Registered: ‎04-04-2011
0

Re: Set Password for My Book Live

Thanks for sharing

 

I don't like the whole idea of changing the Public shares but some users might find this helpful

Click the Kudos star to say thank you for helpful posts and be sure to come back and 'Accept as Solution' under options for the post that solved your issue.
Regular Advisor
Vadir2
Posts: 138
Registered: ‎07-13-2012
0

Re: Set Password for My Book Live

For standard users it will be much easier just create a private share and not store any data to the Public folder.

Occasional Visitor
HenryHall
Posts: 5
Registered: ‎09-02-2012
0

Re: Set Password for My Book Live

When I trty to access /etc/trustees.conf, I get "permission denied". This is when I log in with username:root password:welc0me. Why is this!?!?

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2013 Western Digital Corporation, All rights reserved. | Trademarks | Privacy | Terms of Service | Terms of Use | Copyright | Contact WD