Reply
Occasional Contributor
sarulyos
Posts: 8
Registered: ‎09-07-2011
0

My Book Live can't remote access on internet.

When I update firmware to version 2.x it can't remote access it's has show error message "

You don't have permission to access /UI on this server." I try use function WD2go.com but it's not work because the internet university must have user authentication then I login to WD2go.com it show device offline. Can I have new firmware or method to use my book live on internet same firmware version 1.x (Forwarding Virtual Servers on my router)Capture.PNG

Honored Contributor
TonyPh12345
Posts: 22,808
Registered: ‎01-11-2010
0

Re: My Book Live can't remote access on internet.

You're on a university network?   If so, you won't be able to access it from a different IP subnet.

 

===Live SMP / Live Hub x2 / Live+ / Live x2 / 24 TBytes of QNAP + WD NAS ===
Occasional Contributor
sarulyos
Posts: 8
Registered: ‎09-07-2011
0

Re: My Book Live can't remote access on internet.

[ Edited ]

My book live have IP 10.243.66.1 subnet 255.255.255.0 in my room. But when I use on other place in university I get IP 10.66.243.x subnet 255.255.255.0 . When I remote with IP 10.66.243.250(Forwarding Virtual Servers on my router)  it can't remote access it's has show error message "

You don't have permission to access /UI on this server." This problem have not on firmware 1.x. Can you modify firmwave newversion to support this function for me?

Occasional Contributor
sarulyos
Posts: 8
Registered: ‎09-07-2011
0

Re: My Book Live can't remote access on internet.

[ Edited ]

May be my book live require user authentication internet university.

Capture.PNG

 

Occasional Advisor
CyberSim
Posts: 8
Registered: ‎02-26-2012
0

Re: My Book Live can't remote access on internet.

It's possible to change the firmware (Debian Linux) to remove this limitation:

To enable SSH access to the NAS, go to this page: http://your_mbl_address/UI/ssh

In the file "/etc/network/if-up.d/local-net", comment the following line with a "#":
     # echo "Allow from $LOCAL_NET." >> "${TMP_ALLOW_FILE}"
and add the following line:
     echo "Allow from all" >> "${TMP_ALLOW_FILE}"
Then run the script "/etc/network/if-up.d/local-net" to apply the change.

This change should persist over time and reboot. Maybe a firmware update will require repeat the procedure.

P. S. Use "nano" as a text editor

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2014 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD