Reply
Occasional Contributor
Somnus
Posts: 3
Registered: ‎06-22-2010
0

How can I turn off the default public share?/guest user

everyone in the network could write/delete files in my HD with the guest user...

but the My Book Live setting page says "User access cannot be defined for the default Public Share".

is there anyway can turn off the public share?

Thanks>.<

Honored Contributor
TonyPh12345
Posts: 22,522
Registered: ‎01-11-2010
0

Re: How can I turn off the default public share?/guest user

Your question is better suited to be in the MyBook Live forum, but since I have one as well, I can tell you that no, you can't disable it.

===Live SMP / Live Hub x2 / Live+ / Live x2 / 24 TBytes of QNAP + WD NAS ===
Occasional Contributor
Somnus
Posts: 3
Registered: ‎06-22-2010
0

Re: How can I turn off the default public share?/guest user

sorry posted in wrong place...

 

Thanks for your help.

Just find out that anyone joined the localnet also can create backupfiles without password...

 

I should do more work before I buy it...T.T

 

thanks again....

Advisor
U-PID
Posts: 26
Registered: ‎03-03-2011
0

Re: How can I turn off the default public share?/guest user

I believe you should look into this file.

The answer to your question lies there : 

/etc/trustees.conf

 

It describes which folders of the drive are to be shared, and to which users. The Public share is marked to be acessible to anyone.

 

---------

Warning: only change this file if you really know what you are doing. Also, make a copy before taking any action.

Frequent Advisor
jonj678
Posts: 67
Registered: ‎01-25-2011
0

Re: How can I turn off the default public share?/guest user

Alternatively go into /etc/samba/overall_share and put a # in front of every line of this bit:

 

## BEGIN ## sharename = Public #
[Public]
  path = /DataVolume/shares/Public
  comment = Public Share
  public = yes
  browseable = yes
  writable = yes
  guest ok = yes
  map read only = no
## END ##

That will solve the problem for windows machines, but not for nfs access.

 

Mt /etc/trustees.conf looks like:

[/dev/sda4]/backup/TimeMachine:*:RWBEX:*:smileyvery-happy:U
[/dev/sda4]/backup/SmartWare:*:RWBEX:*:smileyvery-happy:U
[/dev/sda4]/shares/Public:*:RWBEX:*:smileyvery-happy:U

[/dev/sda4]/shares/Data:*:RWBEX:*:smileyvery-happy:U


I don't know what to make of that, as I don't reognise the syntax. Could you shed some light on this please U-PID?

Advisor
U-PID
Posts: 26
Registered: ‎03-03-2011
0

Re: How can I turn off the default public share?/guest user

[ Edited ]

Well, I am no expert. But I believe that trustee adds Access Control Lists support (ACL) to linux, thus extending the well known unix permission system (rwx). ACL is more comprehensive, flexible, powerful. 

 

When you say syntax, I guess that you speak of the RWBEX part. You can find the answer here :

http://www.linuxsecurity.com/resource_files/host_security/trustees-quickstart.html 

In short it is the ACL permissions for the share.

 

Please, don't hesitate to report any findings. I have not tried anything, as I don't have the need to turn off the public share.

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2014 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD