Reply
Frequent Visitor
madrid_MBLDUO
Posts: 3
Registered: ‎04-05-2012
0

Lost UI on My Book Live Duo

Hello,

Fist post about my MBL Duo.

I tried to install serviio in order to compensate from difficulties I got using the DLNA currently intalled (skipping many files etc). It worked more or less well but I probably did something wrong at one point and I have lost apache2 and of course the WEB UI.

Tried to restore to factory setup, with no format then I lost SSH and was obliged to take out the disk and enable ssh mounting the drive on my PC. 

 

Got ssh, did a factory reset with format but unfortunatly this did not give back UI and apache2

 

MyBookLiveDuo:/usr/sbin# apache2
apache2: Could not open configuration file /etc/apache2/apache2.conf: No such file or directory


 

Tried to re-install apache2but I get this error and I really don't know how to proceed (spend at least 10 hours without succes on these issues)

 

 apt-get install apache2
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  apache2: Depends: apache2.2-common (= 2.2.16-6+squeeze4) but it is not going to be installed
  apache2-mpm-prefork: Depends: apache2.2-common (= 2.2.16-6+squeeze4) but it is not going to be installed
  libapache2-mod-php5: Depends: apache2.2-common but it is not going to be installed
  libapache2-mod-xsendfile: Depends: apache2.2-common (>= 2.2.3) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

`apt-get -f install' does not help

 

Any possibility to really come back to factory setup or to install apache2 to get my UI working again ?

Thanks for any advice

Denis

 

 

 

Frequent Visitor
madrid_MBLDUO
Posts: 3
Registered: ‎04-05-2012
0

Re: Lost UI on My Book Live Duo - no changes with last firmware revision

Just a step further but my problem still not solved.

I installed the last firmware update but apparently it does not reinstall apache2

I still do not have the UI (http:mybookliveduo/UI) working.

Denis

 

IN ADDITION

Surprisingly I noticed also that many of the scripts that were present in /usr/local/sbin are not there anymore in particular I miss the /usr/local/sbin/factoryRestore.sh also WinSCP (TFTP) can not connect anymore (maybe something not enabled in ssh ...) therefore I do not know how to do a new factoryRestore

 

LIST OF FILES IN /usr/local/sbin

 

MyBookLiveDuo:/usr/local/sbin# ls
20-checkRAID.sh                   incUpdateCount.pm
README                            isFactoryFresh.sh
changeRunLevel.pl                 listMediaShares.sh
checkAutoUpdate.sh                masterInstall.sh
checkForSshLogin.sh               modDeviceName.sh
clearAlerts.sh                    modMediaServerEnable.sh
cmdMediaServer.sh                 modShareMediaServing.sh
copyImage.sh                      monitorSmartStatus.sh
copySaveSettingsToDir.sh          monitorTemperature.sh
createBackupTally.sh              monitorVolume.sh
createDataVolume.sh               monitorio.sh
disk-param.sh                     partitionDisk.sh
drive_helper.sh                   queueReboot.sh
formatDataVolume.sh               resetButtonAction.sh
freshInstall.sh                   restoreSettingsFromDir.sh
fw_printenv                       rotateLogs.sh
fw_setenv                         schedulerAdd.sh
genAppleVolumes.sh                schedulerExists.sh
genHostsConfig.sh                 schedulerGet.sh
genItunesConfig.sh                schedulerRemove.sh
genMDNSResponderConfig.sh         sendAlert.sh
getDataVolumePercentUsed.sh       sendEmailAlerts.sh
getDefaultSettingsPathForFile.sh  setAfpSignature.sh
getMacAddress.sh                  settingsManager.sh
getMediaServerConnectedList.sh    share-param.sh
getMediaServerDbInfo.sh           updateDefaults.sh
getSaveSettingsList.sh            updateNasUpnpDevice.sh
getSerialNumber.sh                vft
getSmartStatus.sh                 watchTemp.sh
getSystemHealth.sh                wdAutoMountAdm.pm
getSystemState.sh                 wdAutoMountShare.php
getTemperatureStatus.sh           wdAutoMountUdevHandler.pm
getUpdateCounts.pm                wdStatus.sh
getUpnp_uuid.sh                   writeTwonkyContentDir.sh.old
getVolumeStatus.sh


Frequent Visitor
madrid_MBLDUO
Posts: 3
Registered: ‎04-05-2012
0

Re: Lost UI on My Book Live Duo

Try to repost the issue since I got no answer (maybe too critical and I need to send back the disk to repair)

 

Nevertheless if somebody has any answer or experience with the issues I list below, please let me know.

 

What can I do with the problem I have when reinstalling Apache (listed at the end of the email) ?

Is it any possibility to force reinstalling all the system to factory state knowing that a factory reset is not enough ?

Would it be posssible to physically rewrite the entire linux partition with a image copy from another my book live duo  ?

 

 

Thanks in advance for any advice or guidance .... and soory for my bad english (not native speaker)

 

 

apt-get install apache2
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  apache2: Depends: apache2.2-common (= 2.2.16-6+squeeze4) but it is not going to be installed
  apache2-mpm-prefork: Depends: apache2.2-common (= 2.2.16-6+squeeze4) but it is not going to be installed
  libapache2-mod-php5: Depends: apache2.2-common but it is not going to be installed
  libapache2-mod-xsendfile: Depends: apache2.2-common (>= 2.2.3) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

 

 

 

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2013 Western Digital Corporation, All rights reserved. | Trademarks | Privacy | Terms of Service | Terms of Use | Copyright | Contact WD