MyBook Studio II issues: eSATA incompatibility

So I have bought a MyBook Studio II (quad connect, 4 TB RAID0 formatted as NTFS) and plugged it to my home PC, which has a GA Z77X UD3H motherboard supporting 6Gb eSATA. Two issues:

  1. Transfer speed. It’s atrocious for a RAID0 eSATA HDD. The maximum speed CrystalDiskMArk was able to obtain was 130 MB/s in burst mode, which is similar to my internal, 3 year old 1.5 TB Samsung. The average goes at around 109 MB/s, obtained after transferring about 1 TB of full DVD images (so only large files) off my nicely defragmented Samsung. 

  2. Sometimes when I power the drive up it is not recognized by the Operating System. I have to pull out the cable, shut down the machine, shut down the drive, plug everything back in, start the drive, start the machine. The eSATA port is set as hotplug. When this occurs, I can hear the HDDs in the enclosure making click noises, but the disks are not the issue, I think the controller is acting up. Also when that happens the OS hangs for a fraction of a second every 2-3 seconds, including the mouse pointer if I’m moving it around. If I keep the cable conencted, my OS won’t shut down. The exact same behavior occurs on my Lenovo T410 on eSATA.

Any thoughts?

Try running a test with DLG. Check the link below for the steps. 

http://wdc.custhelp.com/app/answers/detail/a_id/940

I am not sure how would that help, but I ran a quick test and all was fine.

Any other ideas?

You said that you had slow transfer rates and disconnection problems, running the test help you to determine if the problem is with the my book or you computer. If you can, try connecting it to another PC to see if the same thing happens. 

Quoting myself, see initial post:

The exact same behavior occurs on my Lenovo T410 on eSATA.

Another update: the disk just disappeared from Device Manager, Disk Manager snap-in, it’s gone. The unit itself looks normal, with leds blinking (idle mode). I just don’t see it anymore as connected to my machine.

Another update. I found this Answer on the WD KB, stating:

Problem:

 

A My Book Premium ES or My Book Studio hard drive connected to a computer using eSATA hangs. This occurs on computers who use Marvell eSATA controllers.

 

Cause:
This issue is caused by an incompatibility of the Marvell eSATA controller and the chipset on the external hard drive.
 
Solution:
The resolution to this issue is to use a different eSATA controller (chipset) or a differernt connection method (USB/FireWire).
 

So… there’s an “incompatibility” which means I paid roughly 500 USD for unusable products. The motherboard has no Firewire, and the only conenctivity I seem stuck with is the USB (which I wanted to avoid in the first place because I have lots of USB devices and no more USB slots). So, who’s to blame? Is it WD chipset being incompatible with Marvell controller or the other way around? Which chipset has out-of-specs eSATA features?