Reply
Occasional Visitor
bluewater71
Posts: 1
Registered: ‎05-02-2012
0

MyBook 2TB won't power up - Open Up or RMA ???

My 9mth old, 2TB MyBook stopped working today. When plugged in it lights up, and after about 5-10 seconds makes a clicking sound and then powers down. The drive is in warranty, so a replacement is possible. However there is some data on there that I would really like to retrieve. After doing some searching, I believe my options are as follows (please let me know if this is right)... 1st. Try new power adapter & see if unit will power up. if not, then either... a. open unit (voiding warranty ) & plug directly into pc/laptop to see if data is accessible. b. Send unit back for RMA replacement, unopened & lose all data... but get a replacement unit. I have already tried multiple power points without success, so now the question is... If I open the unit and attempt to recover the data, what are my likely chances of success? And, is there anything else I should know for this process? - The HDD did not have a password applied, so is unencrypted as far as I know. - The HDD was working perfectly this morning & nothing extreme or unusual has affected it as far as I know. Thanks in advance.
Honored Contributor
Joe_S
Posts: 5,175
Registered: ‎08-04-2010
0

Re: MyBook 2TB won't power up - Open Up or RMA ???

If the drive came with Smartware the data on drive is hardware encrypted. Opeming the drive is a waste of time. Contact WD they'll probably send you another power supply.

Joe

Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the 'Accept as Solution' button for the post that solved your issue.
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2014 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD