Reply
Occasional Visitor
Karsan
Posts: 1
Registered: ‎03-08-2012

My book essential doesnt show up !

Hello,

 

I have a 2TB WD My book essential 3.0, and off late it has been acting very strangly and doesnt get detected by my computer. I tried the following :

 

1. connect it using different USB cables and power connectors

2. connect it to a different PC and lappy

3. Tried installing SES drivers given in support

4. Tried to see if the partition tables are corrupted (but it doesnt show up in testdisk)

5. Check in disk management - none !

 

These are the following messages i get

pic1

 

ScreenHunter_04 Mar. 08 21.38.gif

 

ScreenHunter_03 Mar. 08 21.37.gif

 

 

Ive tried searching various forums for solutions and even mailed customer support ( no response yet ).

Im sure this is a common problem, but can someone please help me with this.

 

 

Thanks for your time :smileyhappy:

Honored Contributor
Wizer
Posts: 3,894
Registered: ‎04-04-2011
0

Re: My book essential doesnt show up !

dude ...

 

don't see the images yet...

 

be back when approved *seats back and reads news paper *

Click the Kudos star to say thank you for helpful posts and be sure to come back and 'Accept as Solution' under options for the post that solved your issue.
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2014 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD