Reply
Member
slotdoc48
Posts: 3
Registered: ‎04-08-2012
0

My Book Essential 3TB USB 3.0 problems after updating firmware

[ Edited ]

I just updated the firmare on my external My Book Essential 3TB USB 3.0 drive, a couple of days ago, and now when I restart the computer the Logitech wireless mouse/keyboard combo is locked up.  I can unplug the USB cable from my computer and the power adapter and  all is well with the mouse and keyboard. I plug the My Book Essential drive back in (USB cable and power adapter ) and everything works fine, drive is recognized and all files on it are listed and accessible.  The My Book Essential external hard drive is recognized by the computer as a 'USB Mass Storage Device - My Book (F:smileyhappy:

 

What can I do to correct this problem.

 

My computer:

HP Pavilion HPE h8-1237c

Windows 7 Home Premium Service Pack 1

10 GB RAM

2 TB HDD

 

Thank You

 

P.S. I have the MY Book Essential external hard drive  connected to the computer via a USB port (supposedly USB 3.0 connection) in the 'upper I/O ports on top of the computer.

 

 

Honored Contributor
Wizer
Posts: 3,894
Registered: ‎04-04-2011
0

Re: My Book Essential 3TB USB 3.0 problems after updating firmware

don't have the keyboard mouse combo you have but it sounds like a driver conflict

 

did you try checking device manager at the moment you are having issues?

 

check for a driver update for the keyboard on logitech's web 

Click the Kudos star to say thank you for helpful posts and be sure to come back and 'Accept as Solution' under options for the post that solved your issue.
Member
slotdoc48
Posts: 3
Registered: ‎04-08-2012
0

Re: My Book Essential 3TB USB 3.0 problems after updating firmware

Thanks for the reply.  Did check that and it said that all was up to date.

Occasional Visitor
drazen
Posts: 1
Registered: ‎04-20-2012
0

Re: My Book Essential 3TB USB 3.0 problems after updating firmware

[ Edited ]

Having the same issue here.

 

Asrock x79 Extreme 4 motherboard

using the ASMEDIA XCHI Controller for USB 3.0 

 

Plug the 3 TB external drive into any of my USB 3.0 ports and the SES device disappears and a USB Mass Storage Device appears appears in conflict (exclamation point).

 

Plug the drive into any USB 2.0 port and the drive is recognized normally, SES device appears and everything is hunky dory.

 

Seems to be somewhat common from what I have seen on the net, but not finding any real solutions.  Sent an email into WD support but have not heard back from them yet.

 

Encountered the problem when I first got it, have since upgraded the firmware but still has the same issue.

 

Member
slotdoc48
Posts: 3
Registered: ‎04-08-2012
0

Re: My Book Essential 3TB USB 3.0 problems after updating firmware

[ Edited ]

Thanks for the info.  Mine started after I upgraded the firmware and it also is recognized as a 'USB Mass Storage Device'.  When I restart computer,   I have to safely remove the drive   then restart computer and once Windows 7 is up and running, I plug the power adapter in and then the USB cable into one of the 2 - USB 3.0 slots and it works fine except that it is recognized as a Mass Storage Device.  Still no solution.  Have been in direct contact with WD support with no luck.

 

Thanks for the reply.

 

Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2014 Western Digital Technologies, Inc. All rights reserved. | Trademarks | Privacy | Community Terms of Service | Site Terms of Use | Copyright | Contact WD