Reply
Occasional Collector
sbto2003
Posts: 1
Registered: ‎06-02-2013
0

2TB My Passport Studio Won't Unmount on Mac Mountain Lion 10.8.2

Hi all..

 

I recently purchased a 2TB My Passport Studio portable bus-powered drive.  I enabled Security on the drive using the supplied WD Security app (v 1.0.5.7, Helper v 1.0.0.11).  All was good initially.

 

Suddenly, with no OS or software changes on my part (I'm in mid-project and a personal rule is not to change anything in the OS or mission critical apps until the gig is done), the drive would not unmount on my Mountain Lion machine (10.8.2).

 

It "greys out" but the ghost image of it stayed on my desktop.  No keystrokes or other usually-useful force eject tricks would work.  What's worse, is that it essentially hung my machine.  Most apps would continue to run but eventually when I had to shut down or restart, the machine would hang and the only way to restart was to force-power cycle (i.e. hold down the power button on the CPU until it shut down).  This happens when interfacing with both FW800 and USB 2.  I have tried multiple cables and no other external volumes are attached.

 

So, I though the drive was dying and contacted WD and asked for an RMA.  The website obliged and I used my Credit Card number to have a replacement drive sent to me before sending the old drive back.  Once I received the replacement drive, I copied all of my data across (a day-long process, copying a VERY large number of media library files) only to discover the new drive was exhibiting the exact same behaviour, right away.

 

Of course, being the trouble-shooting type, this immediately made me think that it was a user error - I must have done something on the Finder level to the drive that was causing it to hang.

 

HOWEVER, when I use the drive (either one, actually  - old and replacement) on a LION system (10.7.5), the drive functions perfectly normally.  I can unmount ("eject") it and mount it faithfully and repeatably.

 

SO, is there a possible Mountain Lion incompatibiltiy issue here?  Either with the hardware, firmware or with the WD Security software?

 

I am really hoping that someone doesn't tell me to update to OS 10.8.3 and test that because (being mid-project) I'm really not in a position to do it.

 

Any insight from anyone?

 

Many thanks in advance.

 

sb

Staff
Ichigo
Posts: 2,557
Registered: ‎02-28-2013
0

Re: 2TB My Passport Studio Won't Unmount on Mac Mountain Lion 10.8.2

Hello sbto2003, avoid connecting the the Passport using USB extension cables or USB hubs. You can also try running the repair option from the disk utility. Check the link below for the steps. 

 

How to test a drive for defects or problems on a Mac

Click the Kudos star on the left to say thank you for helpful posts. And be sure to come back to click the 'Accept as Solution' button for the post that solved your issue. This may help someone else.
Forums | Ideas | News and Announcements | Register | Sign in | Help | Forum Guidelines
Copyright © 2001 - 2013 Western Digital Corporation, All rights reserved. | Trademarks | Privacy | Terms of Service | Terms of Use | Copyright | Contact WD